Sound Blaster SB 16 ISA sound card problems

Sound Blaster SB 16 ISA sound card problems

Post by Kai » Wed, 06 Dec 2000 16:06:51



Hi all,
Here's the go:

I have a streaming audio server, using raencoder and pnserver.
If I have one user listening to the stream no problems, but if someone
else tries to listen to the stream I get this in /var/log/messages:
kernel: Sound: DMA (input) timed out - IRQ/DRQ config error?

I have edited /etc/conf.modules and made sure the settings for my Sound
Blaster SB15 ISA card are corect.
I have tried swapping cards and trying different ISA slots.....still
doesn't improve the situation.
Does anyone have any ideas?

I am running Red hat 6.2 and although I know a little but, I'm
definately no expert on how to use it.

Thanks in advance

Kai

 
 
 

Sound Blaster SB 16 ISA sound card problems

Post by fauzbea » Wed, 06 Dec 2000 04:00:00


With out more information, I would say that the IRQ is being used by
something else
have you tried sndconfig?
You may have to do a manual config of the sound card for it to work
properly.
B

Quote:> Hi all,
> Here's the go:

> I have a streaming audio server, using raencoder and pnserver.
> If I have one user listening to the stream no problems, but if someone
> else tries to listen to the stream I get this in /var/log/messages:
> kernel: Sound: DMA (input) timed out - IRQ/DRQ config error?

> I have edited /etc/conf.modules and made sure the settings for my Sound
> Blaster SB15 ISA card are corect.
> I have tried swapping cards and trying different ISA slots.....still
> doesn't improve the situation.
> Does anyone have any ideas?

> I am running Red hat 6.2 and although I know a little but, I'm
> definately no expert on how to use it.

> Thanks in advance

> Kai


 
 
 

Sound Blaster SB 16 ISA sound card problems

Post by Kai » Thu, 07 Dec 2000 04:00:00


Yes, tried sndconfig and it says all's fine with the sound card !
Playing MP3's and other audio works fine, just encoding is being a
PITA...?

> With out more information, I would say that the IRQ is being used by
> something else
> have you tried sndconfig?
> You may have to do a manual config of the sound card for it to work
> properly.
> B


> > Hi all,
> > Here's the go:

> > I have a streaming audio server, using raencoder and pnserver.
> > If I have one user listening to the stream no problems, but if someone
> > else tries to listen to the stream I get this in /var/log/messages:
> > kernel: Sound: DMA (input) timed out - IRQ/DRQ config error?

> > I have edited /etc/conf.modules and made sure the settings for my Sound
> > Blaster SB15 ISA card are corect.
> > I have tried swapping cards and trying different ISA slots.....still
> > doesn't improve the situation.
> > Does anyone have any ideas?

> > I am running Red hat 6.2 and although I know a little but, I'm
> > definately no expert on how to use it.

> > Thanks in advance

> > Kai

 
 
 

Sound Blaster SB 16 ISA sound card problems

Post by Dual » Thu, 07 Dec 2000 04:00:00



>Hi all,
>Here's the go:

>I have a streaming audio server, using raencoder and pnserver.
>If I have one user listening to the stream no problems, but if someone
>else tries to listen to the stream I get this in /var/log/messages:
>kernel: Sound: DMA (input) timed out - IRQ/DRQ config error?

>I have edited /etc/conf.modules and made sure the settings for my Sound
>Blaster SB15 ISA card are corect.
>I have tried swapping cards and trying different ISA slots.....still
>doesn't improve the situation.
>Does anyone have any ideas?

>I am running Red hat 6.2 and although I know a little but, I'm
>definately no expert on how to use it.

just guessing...

Seems like the server tries to use its soundcard twice when the 2nd
streaming audio client connects

It should simply send the same audio data to both clients , or use
multicasting

DualIP