Static FM Radio using ivtv-radio on Hauppauge PVR-350

Static FM Radio using ivtv-radio on Hauppauge PVR-350

Post by anonyuse.. » Wed, 11 Jan 2006 09:03:30



hey all,

When I try to play radio with ivtv-radio I only get static.
(Scanning for channels / frequencies finds nothing)

I have a Hauppauge PVR-350 running Fedora Core 4 and have
ivtv-0.4.0-98.rhfc4.at installed.

I have tried the card on a windows box and the radio works perfectly
there.  (TV works perfectly on both systems)

Below shows some output and messages in dmesg

Any ideas? Thanks!

Quote:

> ivtv-radio -s

> ivtv-radio -a

> ivtv-radio -f 96.9

set to freq 96.88
Running: aplay -f dat < /dev/video24
Playing raw data 'stdin' : Signed 16 bit Little
Endian, Rate 48000 Hz, Stereo
^C
Aborted by signal Interrupt...
Cleaning up
Quote:>ivtv-radio -f 104.1

set to freq 104.12
Running: aplay -f dat < /dev/video24
Playing raw data 'stdin' : Signed 16 bit Little
Endian, Rate 48000 Hz, Stereo
^C
Aborted by signal Interrupt...
Cleaning up
Quote:

> dmesg | grep -i ivtv

ivtv: no version for "struct_module" found: kernel
tainted.
ivtv:  ==================== START INIT IVTV
====================
ivtv:  version 0.4.0 (tagged release) loading
ivtv:  Linux version: 2.6.14-1.1644_FC4smp SMP 686
REGPARM 4KSTACKS gcc-4.0
ivtv:  In case of problems please include the debug
info
ivtv:  between the START INIT IVTV and END INIT IVTV
lines when
ivtv:  mailing the ivtv-devel mailinglist.
ivtv0: Autodetected WinTV PVR 350 card (iTVC15 based)
ivtv0: Unreasonably low latency timer, setting to 64
(was 32)
tveeprom: ivtv version
ivtv0: i2c attach to card #0 ok [client=tveeprom,
addr=50]

ivtv0: i2c attach to card #0 ok [client=(tuner unset),
addr=61]

#0)
ivtv0: i2c attach to card #0 ok [client=saa7115,
addr=21]

#0)
ivtv0: i2c attach to card #0 ok [client=saa7127,
addr=44]
msp34xx: ivtv version
ivtv0: i2c attach to card #0 ok [client=MSP3448W-A2,
addr=40]
ivtv0: i2c attach to card #0 ok [client=tda9887,
addr=43]
ivtv0: loading /lib/modules/ivtv-fw-enc.bin
ivtv0: loading /lib/modules/ivtv-fw-dec.bin
ivtv0: Encoder revision: 0x02040024
ivtv0 warning: Encoder Firmware can be buggy, use
version 0x02040011 or 0x02050032.
ivtv0: Decoder revision: 0x02020023
ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768
buffers (4096KB total)
ivtv0: Allocate DMA encoder YUV stream: 194 x 10800
buffers (2048KB total)
ivtv0: Allocate DMA encoder VBI stream: 120 x 17472
buffers (2048KB total)
ivtv0: Allocate DMA encoder PCM audio stream: 455 x
4608 buffers (2048KB total)
ivtv0: Create encoder radio stream
ivtv0: Allocate DMA decoder MPEG stream: 16 x 65536
buffers (1024KB total)
ivtv0: Allocate DMA decoder VBI stream: 512 x 2048
buffers (1024KB total)
ivtv0: Create decoder VOUT stream
ivtv0: Allocate DMA decoder YUV stream: 24 x 43200
buffers (1024KB total)
ivtv0: loading /lib/modules/ivtv_init_mpeg.bin
ivtv0: Initialized WinTV PVR 350, card #0
ivtv:  ====================  END INIT IVTV
====================