Newbee needing help installing ethernet driver

Newbee needing help installing ethernet driver

Post by icuche.. » Mon, 17 Jan 2000 04:00:00



I have just installed RedHat 6.1.  All appears to
work fine, except when I tried to put it on my
network, nothing.  ifconfig reports only my
loopback.  /var/log/messages says it is delaying
eth0 when I boot.  I suspect the ethernet driver
is not installed/configured properly.

I have an SMC EtherEX 8416.  I have no idea how to
install/verify/configure drivers or even where to
look for help.  I tried the man pages and the How
To's (man there's alot).  Can anyone help me
please?

Cheryl

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

Newbee needing help installing ethernet driver

Post by Leonard Even » Mon, 17 Jan 2000 04:00:00



> I have just installed RedHat 6.1.  All appears to
> work fine, except when I tried to put it on my
> network, nothing.  ifconfig reports only my
> loopback.  /var/log/messages says it is delaying
> eth0 when I boot.  I suspect the ethernet driver
> is not installed/configured properly.

> I have an SMC EtherEX 8416.  I have no idea how to
> install/verify/configure drivers or even where to
> look for help.  I tried the man pages and the How
> To's (man there's alot).  Can anyone help me
> please?

> Cheryl

> Sent via Deja.com http://www.deja.com/
> Before you buy.

You probably just need to put the appropriate driver module
reference in /etc/conf.modules.   For example, I have

alias eth0 3c59x

for the module 3c59x.o.   By default under RH6.1, the
modules which might be relevant for you are

smc-ultra.o
smc-ultra32.o
smc9194.o

You can try each of these (without the .o).  If none works,
you may be able to find a driver on the web.  See

http://cesdis1.gsfc.nasa.gov/linux/drivers/

--


Dept. of Mathematics, Northwestern Univ., Evanston, IL 60208

 
 
 

Newbee needing help installing ethernet driver

Post by Cory Kemp » Mon, 17 Jan 2000 04:00:00



> I suspect the ethernet driver
> is not installed/configured properly.

> I have an SMC EtherEX 8416.  I have no idea how to
> install/verify/configure drivers or even where to
> look for help.

Drivers live in the kernel, or in loadable kernel modules.

There is a fairly nice, x/menu driven configuration utility
(make xconfig) in the kernel source directory.

It really isn't that hard, once you get the hang of it :-)

+C

--
Have you signed up to be a bone marrow doner?  All it takes is a simple
* test, and it can save a life.  <http://www.veryComputer.com/>

Cory Kempf           Macintosh / Unix Consulting & Software Development

 
 
 

Newbee needing help installing ethernet driver

Post by Bit Twist » Mon, 17 Jan 2000 04:00:00


http://www.redhat.com/corp/support/hardware/intel/61/rh6.1-hcl-i.ld.html
has what module for what card.

You need to set what module is to manage your nic card.

linuxconf
 Config
  Networking
   Client tasks
    Basic host information
     Adapter
 Ok, save and exit.



>I have just installed RedHat 6.1.  All appears to
>work fine, except when I tried to put it on my
>network, nothing.  ifconfig reports only my
>loopback.  /var/log/messages says it is delaying
>eth0 when I boot.  I suspect the ethernet driver
>is not installed/configured properly.

>I have an SMC EtherEX 8416.  I have no idea how to
>install/verify/configure drivers or even where to
>look for help.  I tried the man pages and the How
>To's (man there's alot).  Can anyone help me
>please?

>Cheryl

>Sent via Deja.com http://www.deja.com/
>Before you buy.

--
The warrenty and liability expired as you read the message.
If the above breaks your system, it's yours and you keep both pieces.
Do a,  man every_command_here, before doing anything else.
Backup every file before you change it.
 
 
 

Newbee needing help installing ethernet driver

Post by David M. Co » Tue, 18 Jan 2000 04:00:00




>I have an SMC EtherEX 8416.

Redhat does not list that card (at least under that name) on their HCL:

http://www.redhat.com/support/hardware/intel/61/rh6.1-hcl-i.ld-11.html

However, you could try the various possibilities listed there.  You can test
out modules using the insmod and rmmod commands, e.g.

# insmod tulip

(leave off the .o.)  If there are no errors try bringing up the network:

# ifup eth0

You can configure the network with the netconf command.

If the ifup command returns no errors try pinging something

# ping 192.168.1.5

Otherwise if you do get errors you can remove the module with:

# rmmod tulip

Dave Cook

 
 
 

Newbee needing help installing ethernet driver

Post by Josep » Wed, 19 Jan 2000 04:00:00


OK , some things to check :
Is the card plugged in and working.
When you switch on the computer, the little light on the card shold come on
for a very brief moment. If so, card is seated in the slot properly.
If not,  power off, jiggle card, take it out, blow on the card etc... to
allow a good contact in the slot, but by all means do not use hammer, or
kick or use percussive maintenance :)

Once we get the little pulse of light at switch on ( it is caused by a pulse
of current that's part of the power on self test. )

Once we know the hardware is OK,

If the card is non-pnp , you need the irq and io numbers.
if it is pnp , you will have to use the isapnp program to get the
configuration. And I can't help you there.

I am ok with non-pnp stuff.
if the card has jumpers on it, set it to some free irq, and address
then use ifconfig to set the interface with io= and irq=  ( do man ifconfig
and readup on the params)
alternately you can go to /etc/conf.modules ( I think) and look at the eth0
params given there, modify and reboot .

If this still does not work,  re-install, but this time DO NOT FORMAT any
partitions.
But you must find out the io port and the irq number of the card by looking
at the card or guessing or using some dos utility that can set the card. (My
realtek cards have dos setup programs so i set them to irq=10 io=0x300  a
long time ago, and turned off PNP)
I would also suggest you use the Ne2000 driver for a start.

Good luck


>I have just installed RedHat 6.1.  All appears to
>work fine, except when I tried to put it on my
>network, nothing.  ifconfig reports only my
>loopback.  /var/log/messages says it is delaying
>eth0 when I boot.  I suspect the ethernet driver
>is not installed/configured properly.

>I have an SMC EtherEX 8416.  I have no idea how to
>install/verify/configure drivers or even where to
>look for help.  I tried the man pages and the How
>To's (man there's alot).  Can anyone help me
>please?

>Cheryl

>Sent via Deja.com http://www.deja.com/
>Before you buy.

 
 
 

1. Need Help Installing driver for Ethernet Card

Could someone break down these instructions for installing the driver for
my ethernet card into dummy terms for me ?? including let me know what i
need to substitute in based on my computer !? thanks !!

System Specs:
Compaq Presario 8712
200 Mhz
88 RAM
Caldera OpenLinux 2.3
Sohoware Fast Ethernet Card

(Pasted from readme.txt)

    Linux has a facility for linking device drivers into
the running kernel. This is called Modules support.

    Here's how to make and load the Modules version:

1. Verify that the source code for your current kernel
   version is installed.
   If you don't have a /usr/include/linux/version.h file,
do cd /usr/src/linux; make include/linux/version.h
Copy the driver source code, tulip.c, to a source directory.

2. Compile the file using one of the compile-commands below:

 *  compile-command:
gcc -DMODULE -D__KERNEL__ -I/usr/src/linux/net/inet -Wall -Wstrict-
prototypes -O6 -c tulip.c `[ -f /usr/include/linux/modversions.h ] &&
echo -DMODVERSIONS`

 *  SMP-compile-command (for machines with multi processors):
gcc -D__SMP__ -DMODULE -D__KERNEL__ -I/usr/src/linux/net/inet -Wall -
Wstrict-prototypes -O6 -c tulip.c `[ -f /usr/include/linux/modversions.h ]
&& echo -DMODVERSIONS`

3. Copy tulip.o into the latest kernel's modules:

   cp tulip.o /lib/modules/2.0.XX/net/tulip.o

4. Update kernel's module dependencies:

   /sbin/depmod -a

--
Posted via CNET Help.com
http://www.help.com/

2. Frame Relay card on Solaris

3. Q: Ethernet Device Driver: install/config help needed...

4. New Releases of FreeBSD

5. Xircom Ethernet PCMCIA info needed for the Ethernet driver?

6. Help with Yamaha onboard sound on Seattle2 Intel motherboard

7. Ethernet driver - clarifications and help needed

8. OSI solstice APLI sample initiator fails with conf res AP_REJ_PERM

9. Help, I need and Ethernet card driver.

10. help! Need Ethernet driver for linux.

11. Q: DEPCA Ethernet driver, config help needed

12. Ethernet Device Driver Help Needed

13. HELP: need Intel Ethernet Driver