version info for libpthread.so

version info for libpthread.so

Post by Steffen Jos » Wed, 08 Mar 2000 04:00:00



Hi all!

By mistake I deleted some links to  libraries. I tried to relink them
properly by looking at another computer with linux installed, it is also
running on SuSE 6.2, so I looked at the all links and relinked them on the
broken computer. But I still get some error messages about missing version
information, some programs wont start anymore. (for example xmms)

xmms: /lib/libpthread.so.0: no version information available (required by
xmms) xmms: /lib/libpthread.so.0: no version information available
(required by xmms) xmms: /lib/libpthread.so.0: no version information
available (required by /usr/lib/libgthread-1.2.so.0) xmms: error in loading
shared libraries: /usr/lib/libgthread-1.2.so.0: symbol
pthread_cond_broadcast,  version GLIBC_2.0 not defined in file
libpthread.so.0 with link time reference (no version symbols)

Also reinstalling the right (?) packages didnt solve the problem so far.
What am I doing wrong, and what is this all about? Can anyone help me?
All hints are welcome!
Thanks!

Steffen

 
 
 

version info for libpthread.so

Post by Steffen Jos » Thu, 09 Mar 2000 04:00:00


Hi all!

By mistake I deleted some links to  libraries. I tried to relink them
properly by looking at another computer with linux installed, it is also
running on SuSE 6.2, so I looked at the all links and relinked them on the
broken computer. But I still get some error messages about missing version
information, some programs wont start anymore. (for example xmms)

xmms: /lib/libpthread.so.0: no version information available (required by
xmms) xmms: /lib/libpthread.so.0: no version information available
(required by xmms) xmms: /lib/libpthread.so.0: no version information
available (required by /usr/lib/libgthread-1.2.so.0) xmms: error in loading
shared libraries: /usr/lib/libgthread-1.2.so.0: symbol
pthread_cond_broadcast,  version GLIBC_2.0 not defined in file
libpthread.so.0 with link time reference (no version symbols)

Also reinstalling the right (?) packages didnt solve the problem so far.
What am I doing wrong, and what is this all about? Can anyone help me?
All hints are welcome!
Thanks!

Steffen

 
 
 

1. ld.so.cache: ../lib/libpthread.so.1 => libpthread.so.1.0.0

I installed libpthreads.
My ldconfig says :
.....
.....
/usr/local/lib:
        ../lib/libpthread.so.1 => libpthread.so.1.0.0
        libqt.so.1 => libqt.so.1.2
        libz.so.1 => libz.so.1.0.4
        libtiff.so.3 => libtiff.so.3.4.036
        libpng.so.0 => libpng.so.0.90
        libmpeg.so.1 => libmpeg.so.1.2
        libjpeg.so.6 => libjpeg.so.6.0.1
....
....
My binaries don't like that ../lib/ before libpthread.
When I create link ../lib/libpthread.so to
/usr/local/lib/libpthread.so... it works.

I don't understand this.

Could someone help me ?

I need pthreads for ObjC and GNUStep.
I use Slackware3.2beta but this happens on 3.1 also.

2. Problem in setting up SiS6326 Display card

3. can't find libpthread.so

4. "killer" backup tape hangs Solaris 2.4 (long)

5. libpthread.so.0 missing

6. Two machines on Internet via one SLIP connection?

7. libpthread.so.1, SunOs 5.5.1, & patch 103640-32

8. uudecode and pine

9. libpthread.so.1.0.0 won't load

10. libpthread.so not thread safe?

11. apache module with libpthread.so crashes Apache on RH 6.2

12. libpthread.so.0 missing

13. libpthread.so file