Scrambled mouse cursor in X11?

Scrambled mouse cursor in X11?

Post by Doug O'Lear » Sun, 18 Mar 2001 13:01:12



Hey, all;

I just got a new monitor, plugged it in, reran the Xconfigurator,
selected the right monitor, what not.  

When I get into X11, everything looks great except the mouse cursor; it's
all scrambled and shifting back and forth.  Only the mouse cursor.

Anyone know what's going on and better yet how to fix it?

Thanks.

Doug

--
-------------------
Douglas K. O'Leary
Senior System Admin

 
 
 

Scrambled mouse cursor in X11?

Post by Bob Hau » Mon, 19 Mar 2001 00:43:45




Quote:>I just got a new monitor, plugged it in, reran the Xconfigurator,
>selected the right monitor, what not.  

>When I get into X11, everything looks great except the mouse cursor; it's
>all scrambled and shifting back and forth.  Only the mouse cursor.

Some video cards have problems with the hardware mouse cursor at high
dot clocks.  My cirrus-based laptop for instance.  The fix in my case
was to put "Option sw_cursor" in the Device section of XF86Config.
Maybe your card has a similar option.

--
 -| Bob Hauck
 -| To Whom You Are Speaking
 -| http://www.haucks.org/

 
 
 

Scrambled mouse cursor in X11?

Post by Doug O'Lear » Mon, 19 Mar 2001 04:25:06



says...

Quote:> Some video cards have problems with the hardware mouse cursor at high
> dot clocks.  My cirrus-based laptop for instance.  The fix in my case
> was to put "Option sw_cursor" in the Device section of XF86Config.
> Maybe your card has a similar option.

Hey;

Thanks for the reply; that did the trick!  I appreciate it!

Doug

--
-------------------
Douglas K. O'Leary
Senior System Admin

 
 
 

1. help: scrambled cursor XFree 3.1.1, kernel 1.2.13

XFree86 3.1.1, kernel 1.2.13, Diamond Speedstar Pro VLB (Cirrus 5428).

I recently switched from using the monochrome server to VGA. When I
did, my cursor changed from being a nice little arrow to an unwieldy,
ugly, multi-colored rectangle. I cannot, for the life of me, figure
out what went wrong or how to fix it. Any help would be appreciated.

Thanks,

c
--
---

2. NetBackup users reprazent!

3. X11 Fonts scrambled on PCI Miro 12 SD, everything else is fine

4. Add piix fix up function into pii.c

5. moused and mouse cursor speed

6. Is there any mail dealing programs under solaris?

7. Two minor issues: mouse (not X11), display (X11).

8. 3c590 transmit timeout

9. moused / X11-mouse conflict

10. setting X11 cursors

11. X11 cursor font missing?

12. X11: problem fonding cursor font

13. huge cursors after X11 upgrade