help with loading a module

help with loading a module

Post by Pradeep Suda » Tue, 14 Nov 1995 04:00:00



Hello,
        I am trying to load a driver module. I am using version 1.2.13.
I am getting the following error while loading the module.

Failed to load module! The symbols from kernel 1.2.13 don't match 1.2.13

(The sumbols that don't match contain __outw and __memcpy etc)

Any help will be appreciated.
Pradeep

 
 
 

1. editing modules.conf to load sound driver modules

After installing RH 8 my /etc/modules.conf looked like this:

  > alias parport_lowlevel parport_pc
  > alias eth0 8139too
  > alias sound-slot-0 via82cxxx_audio
  > post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
  >/dev/null 2>&1 || :
  > pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
  >/dev/null 2>&1 || :
  > alias sound-slot-1 es1371
  > post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L
  >/dev/null 2>&1 || :
  > pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S
  >/dev/null 2>&1 || :
  > alias usb-controller usb-uhci

I have an audio pci 128 (es1371) sound card as you can see and couldn't
get any sounds.
However, I quoted out the lines that load the via82cxxx module to
sound-slot-0 and changed sound-slot-1 to sound-slot-0 so that
modules.conf looked like this:

  > alias parport_lowlevel parport_pc
  > alias eth0 8139too
  > ### alias sound-slot-0 via82cxxx_audio
  > ##post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
  >/dev/null 2>&1 || :
  > ##pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
  >/dev/null 2>&1 || :
  > alias sound-slot-0 es1371
  > post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
  >/dev/null 2>&1 || :
  > pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
  >/dev/null 2>&1 || :
  > alias usb-controller usb-uhci

I can now get sounds after rebooting but it sounds a bit scratchy.  Is
there any way I can improve the sound quality.  It sounds much better
under XP.  Would installling the ALSA drivers improve sound qualtiy?

Thanks
James

2. NT/SMB auth from IRIX APACHE?

3. IDE-SCSI module corrupts further module loading on 2.5.50

4. screensaver

5. Sb16 and midi module(can't load module midi)~!

6. How can I view PDF format

7. Failed to load module "ati" (module does not exist,0)

8. FTape 4.x & Iomega Ditto Max

9. load module error--kernel-module version mismatch

10. Load three modules with /etc/modules.conf?

11. using rc.modules to load same module twice

12. load module error--kernel-module version mismatch

13. need help loading network module, please....