Linux v1.1.45, XView v3L5.1 - compile warnings

Linux v1.1.45, XView v3L5.1 - compile warnings

Post by TheDoct » Sat, 15 Oct 1994 10:57:42



Here's my problem.  During installation of XView (version info in subject
line), I keep getting warnings to the effect:
seln.c:32: warning: passing arg 1 of `xv_create` makes integer from
pointer without a cast.

I also get some that say (this one is not a direct quote):
warning: comparison of integer and pointer.

I'm doing the installation of XView right now and don't know whether
it'll work or not.  Over the last few days, I've been
gathering/building/installing quite a bit of software from the
comp.os.announce newsgroup messages.  I also see messages from people who
appear to be successfully running them.  I get these same two messages in
almost everything I try to build (xrn, xvnews, xgopher, xarchie).  Some
actually build and run (although some funtions they provide kill the
whole program or just don't work), while others die and won't build at all.

My question (Finally!) is:
What is wrong here.  
here are the versions of some of my stuff:

gcc = v2.5.8
XFree86 = v2.1.1
libc = 4.5.26
linux = Slackware 2.0
kernel = 1.1.45
XView = 3L5.1 (Today is first install of XView, it has not been on my
system before now.)

I do have the olwm though and it runs fine.  Won't know about after XView
installation 'til it finishes.  It's been building stuff for an hour or
more now...  hmm. It's in ../src/sspkg/drawarea now.

Any help and/or suggestions will be most appreciated.  I'll upgrade
whatever I need to.  Don't know whether I can downgrade anything.  We'll see.

Thanks in advance.


 
 
 

1. XDM/X no '@' sign, sendmail daemon probs, v1.1.45 probs

Well, I have two problems, totally unrelated, that I desperately need
help for (and a third, now that I think of it).

First and most important: Sendmail
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Running Slackware 2.0.1 and using the sendmail that came with it to do
mail-hub duties, sendmail hangs when running as a daemon.  We don't
have any problems with it running from 'inetd,' but we'd obviously
like to get away from doing that.

Symptoms:

Sendmail will pick up if one telnet's to the smtp socket on the
subject machine.  Usually (but not always), it will print the banner.
The first few times, it will even respond to a 'help' command, a 'mail
to:' command, whatever.  After that, it just stops responding.  We put
it in 'inetd.conf' to get mail running, and we've got our
'sendmail.cf' file working the way we want it, but we'd really like to
run it as a daemon.  Any clues?

Second and also important: X from XDM
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
When I set things up (using the default entries in the 'inittab' file)
to start XDM on boot, all goes well, EXCEPT:
When I start an X-term in my session (either as root or myself, if it
matters), most things work as one would expect.  One glaring ommission

before it can even be written into the .bash_history file.  Makes it

When I run X using startx from a console session, everything works
fine.  HELP!

Third and much less important: kernel 1.1.45 with ytalk and pppd
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
I built a 1.1.45 kernel (so I could play X-Doom!) and it mostly works
fine, but there are a couple of things I'm having trouble with.
First, 'pppd' seems to be broken.  I went to all this trouble to get
ppp-on and ppp-off scripts working, and now they won't do much of
anything.  *grumble*

Furthermore, when I'm dip/slip'ed in, and try ytalk, it breaks after
only a few characters.  I 'suspect' that these two are related.  I
haven't found any other problems, but then, I've only had that kernel
for 18 hours, and I wasted six of them sleeping.

Any help gratefully (and I hope graciously) accepted.
--
)\,__,/(     __ \    _ \    __ \    _ \    _ \  o David Negaard

 \(~~)/    __/    \___/  _/      \__ /  \___/   o 700 College Avenue

--
)\,__,/(     __ \    _ \    __ \    _ \    _ \  o David Negaard

 \(~~)/    __/    \___/  _/      \__ /  \___/   o 700 College Avenue

2. NFS Installation - Solved

3. ftape and linux-1.1.45

4. PPTP Through linux

5. setiathome

6. KDE 1.45/Suse 6.4>>>Kmenu problem

7. linuxconf no longer include on Red Hat 7.3 ... how...

8. Sudo V1.3 compile warnings

9. XVIEW- where is the latest for Sol 5.7, Xview 3.2 producing compile errors...

10. xview/xview.h, ... files not found when compiling.

11. SATAN v1.1.1 [released] and v1.1.4 [experimental] both do not compile on Redhat 6.0.

12. Need help compiling Linux port of XView (pl1 + sunsite linux patches)