Problem with multi-group membership? SOLVED

Problem with multi-group membership? SOLVED

Post by Torsten Poulin Niels » Sun, 04 Feb 1996 04:00:00



The problem went away when I installed all of XFree86 3.1.2.
Sorry for bothering you all ...

Best regards
Torsten

--


"Felix qui potuit rerum cognoscere causas" - Virgil

 
 
 

1. Problem with multi-group membership?

I am experiencing a somewhat strange behaviour with users
belonging to multiple groups.

Let's say I have a user jdoe belonging to group users and
add him to a group work in /etc/group with a line like
work::101:jdoe

When jdoe is locked in from a VT, id and groups correctly
states that he belongs to the groups users and work. If,
however, he is locked in from X (via xdm), i.e., using an
xterm, the groups are reported as users and root! It seems
like it is only the reporting that is wrong, though I am not
entirely convinced.

Does anyone know what is causing this anomaly? And how do I
circumvent it? Using su from xterm gives me the correct groups.

The system runs a 1.2.13 kernel and XFree 3.1 (except for the
server proper, which is 3.1.2). id and groups are both
GNU sh-utils 1.12.

Thanks in advance,
Torsten
--


"Felix qui potuit rerum cognoscere causas" - Virgil

2. diskless client nfs root

3. Group membership for a group

4. A lpd interceptor

5. Group membership problem

6. Idle telnet sessions being killed

7. More than 32 group membership problem

8. VIRUS DETECTORS

9. ? multi home + multi cgi, multi email, multi log, multi support

10. multi-group posts... AHHHHHHHHHHHHHHHH!!!!!

11. How to do automatic group membership?

12. group memberships

13. Membership of group