UMSDOS,Loadlin & hardware reset

UMSDOS,Loadlin & hardware reset

Post by Mike Big » Wed, 17 Jan 1996 04:00:00



Does anyone have a fix or information on the problem of doing a
hardware reset?  I am using Slackware 3.0, booting linux using loadlin
on a umsdos filesystem. A 'shutdown -r' or 'reboot' does not work. I
tried using a small program that does a hardware reset (posted
by someone previously) but that did not seem to work either.
If I boot from the install disks, the reset works fine. So, it would
seem as though the problem lies with loadlin or UMSDOS.
Any information on this problem would be appreciated.....

Mike Bigus

 
 
 

UMSDOS,Loadlin & hardware reset

Post by Bill Bartle » Thu, 18 Jan 1996 04:00:00


This problem is not unique to umsdos.  I have to same problem
booting to a Linux partition.  So it must either be loadlin or
some change in the kernel is needed.

 
 
 

1. Boot problems with UMSDOS,loadlin and lilo

I am having trouble booting my linux system.  I have it setup as follows.


Filesystem         1024-blocks  Used Available Capacity Mounted on
/dev/hda3              57830   38016    19814     66%   /
/dev/hda4              63215   57234     2717     95%   /usr
/dev/hda2              33884   30420     1714     95%   /usr/src
/dev/hda1             374168  352288    21880     94%   /DOS2

The hda1 is a dos partition.  hda3 (d: drive to dos) has my root file system.
It is also a umsdos partition.  hda2 and 4 are ext2.
I can boot fine using an old version of loadlin and an old kernel (2.0.27).
This command works.
d:\loadlin\loadlin  d:\linux\vmlinuz.27  root=/dev/hda3  rw  vga=3

Using the same basic command
d:\loadlin\loadlin  d:\linux\vmlinuz3  root=/dev/hda3  rw  vga=3
with a new kernel 2.0.30 which I just installed off Redhat 4.2, it makes
it through the boot process to about here

Sep 11 19:20:10 localhost kernel: Started kswapd v 1.4.2.2
Sep 11 19:20:10 localhost kernel: FDC 0 is an 8272A
Sep 11 19:20:10 localhost kernel: Partition check:
Sep 11 19:20:10 localhost kernel:  hda: hda1 hda2 hda3 hda4
Sep 11 19:20:10 localhost kernel: UMSDOS Beta 0.6 (compatibility level 0.4, fast msdos)
Sep 11 19:20:10 localhost kernel: Mounting root

and then it locks up saying unable to open virtual console.  I have to hard
reboot here.  (Above is from a good boot so it might be slightly different.)

I have also tried to get lilo to work.  Here is my lilo.conf.


boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50

Image=/vmlinuz
lable=Linux.old
root=/dev/hda3

Image=/boot/vmlinuz
lable=linux
root=/dev/hda3

other=/dev/hda1
table=/dev/hda
lable=dos


Added vmlinuz *
Syntax error near line 8 in file /etc/lilo.conf

I get this error and am unable to go on.

Any suggestions.  It works fine loading 2.0.27, but I would like to update
someday.
Thanks,
Kerry Nice

2. Ethernet card timeout set and check

3. Help: LOADLIN / UMSDOS installation [compaq aero]

4. ww.google.com won't redirect

5. Kernel 1.2.8x broke Loadlin and/or UMSDOS

6. VxWorks target bootup problem sometimes

7. loadlin won't load umsdos

8. boot problems with 2.2.0-pre5

9. Compiling kernel for UMSDOS (+loadlin)

10. Help with UMSDOS/LOADLIN !!!

11. UMSDOS/LOADLIN vs. ext2/LILO preformance?

12. Debian loadlin error w/scsi "bus device reset"

13. Win95 && Loadlin to load Linux