Exceed & Linux: Configuration Problem

Exceed & Linux: Configuration Problem

Post by Chri » Fri, 17 Sep 1999 04:00:00



Hi All

I have been stuck on this problem for months!

I got two PCs one running linux, other win98.

On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
CDE from the win pc. I start exceed Xstart with command parameter:

xterm -display 192.168.0.1:0.0

I get the xterminal on the win machine with no problems. When I start
netscape/ghostview etc.. (any application the output is ok and it appears on
the win98 monitor).

when I type startx, it starts on the Linux PC.

Could someone PLEASE PLEASE help me out with this. I am not sure if the
problem is from exporting DISPLAY (shouldnt because it works ok with other
progs). I dont know if its an exceed configuration problem.

Thanks
Chris

 
 
 

Exceed & Linux: Configuration Problem

Post by Adrian Hand » Fri, 17 Sep 1999 04:00:00



> Hi All

> I have been stuck on this problem for months!

> I got two PCs one running linux, other win98.

> On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
> CDE from the win pc. I start exceed Xstart with command parameter:

> xterm -display 192.168.0.1:0.0

> I get the xterminal on the win machine with no problems. When I start
> netscape/ghostview etc.. (any application the output is ok and it appears on
> the win98 monitor).

> when I type startx, it starts on the Linux PC.

> Could someone PLEASE PLEASE help me out with this. I am not sure if the
> problem is from exporting DISPLAY (shouldnt because it works ok with other
> progs). I dont know if its an exceed configuration problem.

> Thanks
> Chris

I think there's some other icon you need to click on in exceed.
It will come up with a small dialog box listing hosts "willing to
manage".
Your linux box should be in that list.
Click on it and your xdm/gdm program should display on your windows
screen.

 
 
 

Exceed & Linux: Configuration Problem

Post by Jack Auber » Sat, 18 Sep 1999 04:00:00


I hope somebody can answer this one, I came here with precisely the same
problem (except that I have Win NT rather than 98).  And I couldn't find
anything under any of the Exceed menus that show any promise.  We should be
able to send the window to do Linux configuration chores to the remote
window, no?  Startx just seems to run on the Linux box without sending
anything to the NT window.  But other programs do.


Quote:>Hi All

>I have been stuck on this problem for months!

>I got two PCs one running linux, other win98.

>On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
>CDE from the win pc. I start exceed Xstart with command parameter:

>xterm -display 192.168.0.1:0.0

>I get the xterminal on the win machine with no problems. When I start
>netscape/ghostview etc.. (any application the output is ok and it appears
on
>the win98 monitor).

>when I type startx, it starts on the Linux PC.

>Could someone PLEASE PLEASE help me out with this. I am not sure if the
>problem is from exporting DISPLAY (shouldnt because it works ok with other
>progs). I dont know if its an exceed configuration problem.

>Thanks
>Chris

 
 
 

Exceed & Linux: Configuration Problem

Post by TA Ruhlan » Sat, 18 Sep 1999 04:00:00



> Hi All

> I have been stuck on this problem for months!

> I got two PCs one running linux, other win98.

> On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
> CDE from the win pc. I start exceed Xstart with command parameter:

> xterm -display 192.168.0.1:0.0

> I get the xterminal on the win machine with no problems. When I start
> netscape/ghostview etc.. (any application the output is ok and it appears on
> the win98 monitor).

> when I type startx, it starts on the Linux PC.

> Could someone PLEASE PLEASE help me out with this. I am not sure if the
> problem is from exporting DISPLAY (shouldnt because it works ok with other
> progs). I dont know if its an exceed configuration problem.

> Thanks
> Chris

Have you looked in the startx script on your system? The one on my
system (Mandrake 6.0) has a line:

display=:0  

in it. That might be the source of your problem. The other suggestion I
would make is perhaps you should look for a way to use xdm on the exceed
box rather than startx.

HTH.

--
+--------------------------------------------------------------+
+ Timothy A. Ruhland - Computer Applications, Control Systems, +
+                      Design and Specification                +
+ Rochester, NY 14623-1737                                     +
+--------------------------------------------------------------+

 
 
 

Exceed & Linux: Configuration Problem

Post by Jan Just Keijs » Sat, 18 Sep 1999 04:00:00




>I hope somebody can answer this one, I came here with precisely the same
>problem (except that I have Win NT rather than 98).  And I couldn't find
>anything under any of the Exceed menus that show any promise.  We should be
>able to send the window to do Linux configuration chores to the remote
>window, no?  Startx just seems to run on the Linux box without sending
>anything to the NT window.  But other programs do.



>>Hi All

>>I have been stuck on this problem for months!

>>I got two PCs one running linux, other win98.

>>On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
>>CDE from the win pc. I start exceed Xstart with command parameter:

>>xterm -display 192.168.0.1:0.0

>>I get the xterminal on the win machine with no problems. When I start
>>netscape/ghostview etc.. (any application the output is ok and it appears
>on
>>the win98 monitor).

>>when I type startx, it starts on the Linux PC.

>>Could someone PLEASE PLEASE help me out with this. I am not sure if the
>>problem is from exporting DISPLAY (shouldnt because it works ok with other
>>progs). I dont know if its an exceed configuration problem.

Just to be sure we're talking about the same thing:

- xterm -display <NT-PC:0> works
- startx -display <NT-PC:0> does not work

That does not really surprise me; with 'startx' you're trying to start the X
server, but there already is an X server running on your PC - eXceed !

What you want to do is to enable XDMCP on your eXceed installation (somewhere
in the control panels for eXceed) and then choose an XDMCP session from your
Linux host.

Some people have reported problems with this setup when using gdm/kdm instead
of the plain old X11 'xdm' - if so, please make sure you are starting
/usr/X11R6/bin/xdm.

HTH,

JJ

----------------------------------------------------------
                 *NOTE*
   My Email return address is not correct
    in order to avoid mass mailings...
     These are the correct addresses
     (but with dashes between all letters):

  Jan Just (JJ) Keijser
  Unix Support Engineer / Configuration Manager
  Logica Inc. - Lexington MA


  Just to confuse some of those junkmailers:

  Your mouse has moved. Windows must be restarted for
    the change to take effect. Reboot now? [OK]

  My views are my own...
                    flames > /dev/null 2>&1
----------------------------------------------------------

 
 
 

Exceed & Linux: Configuration Problem

Post by Wallace Barne » Sat, 18 Sep 1999 04:00:00


startx is meant to start an X session on the local machine. To run the X session
on the WinXX machine(s), make sure that xdm is running on the linux box (it
handles the x session requests/login). Then start one of the window managers
that come with Exceed (HWM,MWM). A popup windows should appear asking which
server you would like to host your X services. Select your Linux box (or enter
it's IP). The xdm on the Linux box should kick in with the login/passwd box.
Upon proper authentication, it will kickstart your X session. This is what I do
at work. Good Luck.

-Wally


> Hi All

> I have been stuck on this problem for months!

> I got two PCs one running linux, other win98.

> On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
> CDE from the win pc. I start exceed Xstart with command parameter:

> xterm -display 192.168.0.1:0.0

> I get the xterminal on the win machine with no problems. When I start
> netscape/ghostview etc.. (any application the output is ok and it appears on
> the win98 monitor).

> when I type startx, it starts on the Linux PC.

> Could someone PLEASE PLEASE help me out with this. I am not sure if the
> problem is from exporting DISPLAY (shouldnt because it works ok with other
> progs). I dont know if its an exceed configuration problem.

> Thanks
> Chris

 
 
 

Exceed & Linux: Configuration Problem

Post by Charles Mul » Mon, 20 Sep 1999 04:00:00




Quote:

>Hi All

>I have been stuck on this problem for months!

>I got two PCs one running linux, other win98.

>On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
>CDE from the win pc. I start exceed Xstart with command parameter:

>xterm -display 192.168.0.1:0.0

>I get the xterminal on the win machine with no problems. When I start
>netscape/ghostview etc.. (any application the output is ok and it appears on
>the win98 monitor).

>when I type startx, it starts on the Linux PC.

>Could someone PLEASE PLEASE help me out with this. I am not sure if the
>problem is from exporting DISPLAY (shouldnt because it works ok with other
>progs). I dont know if its an exceed configuration problem.

>Thanks
>Chris

startx starts an X server on the linux box - just what you are seeing

you have to have xdm (or kdm or gdm) running on the linux box and set up
an XDMCP session in your win9x x-server (exceed) to do what I think you want

take a look at

http://www.msu.edu/~mulksc/LinuxHints/win95xserv.html

for complete details as to how I did it using X-Win32

 
 
 

Exceed & Linux: Configuration Problem

Post by Sam Ster » Sun, 31 Oct 1999 04:00:00


On Fri, 17 Sep 1999 16:18:08 +0000, TA Ruhland



>> Hi All

>> I have been stuck on this problem for months!

>> I got two PCs one running linux, other win98.

>> On the win98 pc, I got exceed installed and I want to run e.g. xf86 or the
>> CDE from the win pc. I start exceed Xstart with command parameter:

>> xterm -display 192.168.0.1:0.0

>> I get the xterminal on the win machine with no problems. When I start
>> netscape/ghostview etc.. (any application the output is ok and it appears on
>> the win98 monitor).

>> when I type startx, it starts on the Linux PC.

>> Could someone PLEASE PLEASE help me out with this. I am not sure if the
>> problem is from exporting DISPLAY (shouldnt because it works ok with other
>> progs). I dont know if its an exceed configuration problem.

>> Thanks
>> Chris

>Have you looked in the startx script on your system? The one on my
>system (Mandrake 6.0) has a line:

>display=:0  

>in it. That might be the source of your problem. The other suggestion I
>would make is perhaps you should look for a way to use xdm on the exceed
>box rather than startx.

>HTH.

Hi!

I run exceed 6.1.0.0 and connect to my RH6.1 box running xfree 3.3.5
using ssh to establish the connection and port forwarding while I run
the actually x session via Exceed in either query or passive mode.

Before I give you the answer I use, I will make a few assumptions:

1) You have started xdm on the linux system via run level 5 or via
startx
2) you have enabled authentication in the appropriate manner (xhost,
Xaccess,  etc.)
3) you have configured your two systems to mutually trust each other
via xauth and xhost (linux), xhosts (exceed), rxplugin and xrx plug in
menus

Okay.

Now this is what works for me (when I don't use query mode to access a
logging screen:

1) establish the session via telent, SSLtelent, or ssh
2) in the linux session set the environment variable DISPLAY (NB:ALL
CAPS". to DISPLAY=192.168.0.1:0.0
3) Test that you typed it correctly via echo $DISPLAY
4) now begin your x window session via:
<prompt> gnome-session &
- or -
xterm &
- or -
netscape &
 etc.
DONOT FORGET THE TRAILING & or you will be locked out of the linux
session.

5) you may want to "xauth generate 192.168.0.1:0.0 . trusted" from
time to time.

Now, as a side note, you can also edit the /etc/X11/xdm/Xaccess and
add the line
192.168.0.1
 to enable the ability to log into your system from a query or
broadcast mode X session.

As a second asides, to start emacs from the linux session use "emacs
-nw" and the emacs session will display in text mode.

HTH,

 
 
 

1. Exceed configuration problem

trying to start a new client session to rh6.1 box from nt4 running exceed6.0

problem: after I run the script, the client hang for 1min and then the
dialogue titled "Enter Reply For Prompt" is returned with the message:

Timed out waiting for prompt:
?y ?y ?y#?y'

Please HELP!!!

Sent via Deja.com http://www.deja.com/
Before you buy.

2. This is VERY wacky

3. Exceed & CDE with AIX: fonts & beep questions

4. Problem with Qlogic's target driver use package isp_dist

5. Exceed & RedHat 6.2 Problem

6. Unknown PCI device

7. &&&&----Looking for a unix shell------&&&&&

8. Shadow File

9. ppp && PPPoE && ADSL && net && buffer(s)

10. &#27809;&#26377;&#20154;&#29992;&#20013;&#25991;&#21527;&#65311;

11. problem configuring Exceed for RH Linux

12. &&&&&& SUGGESTION ??? &&&&&&&&

13. exceed & rh 6.1 xdmcp