: MuSE vs. ALSA (CVS Tree)

: MuSE vs. ALSA (CVS Tree)

Post by Young4er » Thu, 19 Jul 2001 22:27:24



Hi,

I am trying to install alsa from the CVS tree on my Linux system composed
of AMD Athlon + Asus K7M Mobo.  The "/etc/modules.conf" for the ALSA setup
is as follows:

        alias   char-major-116          snd
        alias   char-major-14           soundcore

        #
        # snd-card-0
        #  ALSA portion
        #
        alias   snd-card-0              snd-card-via686a

        #
        #  OSS portion
        #
        alias   sound-slot-0            snd-card-0
        alias   sound-service-0-0       snd-mixer-oss
        alias   sound-service-0-1       snd-seq-oss
        alias   sound-service-0-3       snd-pcm-oss
        alias   sound-service-0-8       snd-seq-oss
        alias   sound-service-0-12      snd-pcm-oss

I can play midi songs through kmidi, but not with muse that I downloaded
from http://muse.seh.de (muse requires > ALSA 0.9.0 beta1).  When I
executed muse, I got the following error messages:

#####
audio device <VIA 82C686A>
initPluginInstance: cannot map 2 ports to 1 channel
initPluginInstance: cannot map 2 ports to 1 channel
initPluginInstance: cannot map 2 ports to 1 channel
initPluginInstance: cannot map 2 ports to 1 channel
ALSA lib pcm_hw.c:574:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed:
Device or resource busy
initPluginInstance: cannot map 2 ports to 1 channel
initPluginInstance: cannot map 2 ports to 1 channel
initPluginInstance: cannot map 2 ports to 1 channel
initPluginInstance: cannot map 2 ports to 1 channel
#####

and the following error messages on the xconsole:

#####
Jul 18 09:17:52 modprobe: modprobe: Can't locate module sound-service-3-2
Jul 18 09:17:52 modprobe: modprobe: Can't locate module sound-service-1-2
Jul 18 09:17:52 modprobe: modprobe: Can't locate module sound-slot-2
Jul 18 09:17:52 modprobe: modprobe: Can't locate module sound-service-2-2
Jul 18 09:17:52 modprobe: modprobe: Can't locate module sound-slot-3
Jul 18 09:17:52 modprobe: modprobe: Can't locate module sound-service-3-2
#####

Obviously, no sound will come out from the speakers when I tried to play
any midi songs through muse.  On the other hand, the xconsole error
messages reported that modprobe "Can't find module sound-service-3-2".  
What's module sound-service-3-2, anyway?  Is there a pointer on this module?

TIA.

 
 
 

1. current CVS tree vs released CVS tree

Hello,

I can't seem to find any documentation regarding the different directory
structures from the current (dev) CVS tree and the released structure.

In the releases, the source is in src/*

In the current (dev) CVS tree, the source is broken up into a few
directories:

    example:
        basesrc/*
        syssrc/*

Does anyone know why this is done this way?  Doesn't this confuse the
Makefiles?

 Thanks for any help.

 -Chris

2. DEC Alpha's for $1149.00!!!

3. Asus K7M Sound VS. ALSA CVS

4. STT-Mailgate: comp.os.linux.networking

5. Sound on Asus K7M Mobo vs. ALSA Driver CVS

6. xcdroast-0.96e: Error: No /dev/sr-Devices found.

7. ALSA-0.9beta7 or CVS vs. VIA686a

8. XDR-library

9. via82c686a/b vs. alsa-driver vs. synthesizer

10. Latest CVS Tree available for ftp install?

11. problem with installing gtk+ from cvs source tree.

12. Problem To Compile Alsa (CVS)

13. In Germany with CVS tree and ZIP drive?