RH6.0: mouse problem in text mode

RH6.0: mouse problem in text mode

Post by Neno » Thu, 01 Jul 1999 04:00:00



I am running RH6.0 and have a normal serial logitech mouse (3 buttons)
on /dev/ttyS0 configured by mouseconfig as "Microsoft" type. (I guess it

is an alias for "ms").
In X mode my mouse works perfectly.
In text mode with the gpm daemon running, I see the mouse moving as I
want and the copy & paste feature works too.
The problem is when I run Midnight Commander. The buttons don't work (I
cannot pull down the menus, moving through the directories and so on).
Something much strange happen when using Lynx. The left button doesn't
work and pressing the middle one, lynx seems to enter in a loop moving
everywhere, changing url, saving configurations (???).
Running the mev utility I can see the mouse events are trapped correctly

(each button is identified, press and release events too, movements too
and so on).
Before using RH6.0 I have used for a few days a Debian distribution and
in that case the mouse was working correctly both in text and X modes.

Another thing I don't understand:
Running linuxconf (both in text mode or within KDE and with my mouse
moving on the screen),  and quitting without making any change, it says
the status is not in sync with the current configuration and when I ask
to see what is to be updated it says that '/etc/rc.d/rc3.d/S85gpm start'

is to be executed.

Is out there someone with a suggestion ?

 
 
 

RH6.0: mouse problem in text mode

Post by Jon Ske » Fri, 02 Jul 1999 04:00:00



> In text mode with the gpm daemon running, I see the mouse moving as I
> want and the copy & paste feature works too.
> The problem is when I run Midnight Commander. The buttons don't work (I
> cannot pull down the menus, moving through the directories and so on).

Do you know for sure that you should be able to?

Quote:> Something much strange happen when using Lynx. The left button doesn't
> work and pressing the middle one, lynx seems to enter in a loop moving
> everywhere, changing url, saving configurations (???).

Chances are you've got something in the cut buffer and the middle button
is pasting it - lynx then thinks you've issued a load of commands.

--

http://www.pobox.com/~skeet/

 
 
 

RH6.0: mouse problem in text mode

Post by Neno » Mon, 05 Jul 1999 04:00:00




> > In text mode with the gpm daemon running, I see the mouse moving as I
> > want and the copy & paste feature works too.
> > The problem is when I run Midnight Commander. The buttons don't work (I
> > cannot pull down the menus, moving through the directories and so on).

> Do you know for sure that you should be able to?

Because I still cannot use the mouse in any text based application, I am
guessing the problem is not related to Midnight Commander or Lynx. I
know that these programs support the mouse...

Just to know if the problem was in the gpm package 1.7.5-3 provided in
my RH6.0 CDrom, I have installed an older version but the problem is
still the same.
(Before RH6.0 I used for a few weeks a Debian distribution and I didn't
have this problem).

Supposing gpm have nothing to do with this problem, what other
program/package the mouse management depends on?

(I remind you that in X, with or without gpm, my mouse works)

Bye..

 
 
 

1. RH6.0: mouse problem in text mode

I am running RH6.0 and have a normal serial logitech mouse (3 buttons)
on /dev/ttyS0 configured by mouseconfig as "Microsoft" type. (I guess it

is an alias for "ms").
In X mode my mouse works perfectly.
In text mode with the gpm daemon running, I see the mouse moving as I
want and the copy & paste feature works too.
The problem is when I run Midnight Commander. The buttons don't work (I
cannot pull down the menus, moving through the directories and so on).
Something much strange happen when using Lynx. The left button doesn't
work and pressing the middle one, lynx seems to enter in a loop moving
everywhere, changing url, saving configurations (???).
Running the mev utility I can see the mouse events are trapped correctly

(each button is identified, press and release events too, movements too
and so on).
Before using RH6.0 I have used for a few days a Debian distribution and
in that case the mouse was working correctly both in text and X modes.

Another thing I don't understand:
Running linuxconf (both in text mode or within KDE and with my mouse
moving on the screen),  and quitting without making any change, it says
the status is not in sync with the current configuration and when I ask
to see what is to be updated it says that '/etc/rc.d/rc3.d/S85gpm start'

is to be executed.

Is out there someone with a suggestion ?

2. how to setup Network

3. H.323 Stacks for Linux

4. RH6.0 - mouse problem in text mode

5. PPP on Linux 1.2.13 Can dial up but then it's over

6. Mouse problems (text mode & X-Windows)

7. Efficiency of output to /dev/null?

8. RH6.2: Power Management in Text Mode

9. HELP!: MOUSE IN TEXT-MODE!

10. Can't get mouse pointer in text mode

11. PS/2 Mouse in Text Mode; X won't start

12. how to enable mouse in text-mode ?