sound for non-root users?

sound for non-root users?

Post by nmanc.. » Thu, 09 Sep 1999 04:00:00



i'm having some trouble getting sound to work on
my red hat 6 machine.  well, i can get it working
fine while running as root, but not with any other
user account.

while trying to enable sound support in
enlightenment (dr15), i get the message 'unable to
communicate with Esound.' (or something to that
extent.)

once again, everything works fine while running as
root, but once i log in as a normal user, it
doesn't.  any suggestions?

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

 
 
 

sound for non-root users?

Post by Jan Houtsm » Thu, 09 Sep 1999 04:00:00



> i'm having some trouble getting sound to work on
> my red hat 6 machine.  well, i can get it working
> fine while running as root, but not with any other
> user account.

> while trying to enable sound support in
> enlightenment (dr15), i get the message 'unable to
> communicate with Esound.' (or something to that
> extent.)

> once again, everything works fine while running as
> root, but once i log in as a normal user, it
> doesn't.  any suggestions?

> Sent via Deja.com http://www.deja.com/
> Share what you know. Learn what you don't.

check if your sound devices in /dev have write permissions
for users.  By default in RH6.0 they were only writable
for root. So do a chmod 660 or whatever.

e.g. on my box for soundblaster 64 value:

jan:/home/jan/> ls -al /dev/sdb
brw-rw----   1 root     disk       8,  16 May  5  1998 /dev/sdb
    ^^
    !! writable!

b.t.w. this also applies to the modem device etc. etc.

jan