Font display problems in matlab when using VNC (an X resources problem?)

Font display problems in matlab when using VNC (an X resources problem?)

Post by Ton » Tue, 23 Jul 2002 09:57:05



Hi Gang,
I hope that one of you can point me in the correct direction on a
problem I am having.

I am now using the VNC on my XP machine to view a matlab sesion on a
remote RH 7.2 linux system.  I used to use exceed and it was quite
slow over DSL.  VNC is much faster, but I am having problems with
reading fonts on matlab figures and dialog boxes.

When I use VNC I get dashed boxes instead of text for the toolbar.
For instance, instead of having a file menu item I see three boxes.
The tooltips are also displaying boxes instead of text.  When I click
the boxes the file command works properly.  I get a similar problem
with save as dialog boxes.

When I ran matlab over exceed I do not have any problems reading the
fonts and everything works fine.

I looked around and saw a MATWORKS FAQ on that appears germane to this
issue (http://www.mathworks.com/support/solutions/data/2472.shtml).
Basically this FAQ indicates that I need to set some matlab resources
in my .Xdefault file and that I probably have problems with the font
that matlab is using in the figure and dialog boxes.  I tried to
follow the FAQs advice and put the line

Matlab*figure*XmRowColumn*fontList:
-*-helvetica-medium-r-normal--14-*-*-*-*-*-*-*

and then

Matlab*figure*fontList: -*-helvetica-medium-r-normal--14-*-*-*-*-*-*-*

in my .Xdefault file, but they had no effect on this problem.  I tried
to run editres to see what x resources matlab uses, but editres did
not work with the matlab gui.

Hopefully someone can help me turn boxes into text.  

In addition, It would be great if someone could send me a link that
lists all the x resources that matlab uses.

Thanks, Tony


Thanks!

 
 
 

1. display kde problems using vnc.

Hi,

I have vnc installed (version 3) on a SuSE 7.2 box
I can display the kde screen fine however when I
try to access any kde applications kppp etc
I get the following.

QImage::color: Index 0 out of range
QImage::color: Index 218 out of range
QImage::color: Index 218 out of range
QImage::color: Index 255 out of range
Qt: Locales not supported on X server
Xlib:  extension "RENDER" missing on display ":1.0".
Qt: Locales not supported on X server
Xlib:  extension "RENDER" missing on display ":1.0".
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = konsole path = <unknown>

Any ideas ?

Regards

Matt

2. hard links

3. Display problem (I think) with VNC Please help!!!

4. KNewsTicker

5. VNC font problem

6. PROBLEM: kernel BUG at page_alloc.c:91!

7. VNC xstartup (grey screen) - $DISPLAY problems?

8. Mailx and attachment

9. VNC font Problem

10. Problems using fonts.alias to replace Type1 fonts with Truetype

11. OpenBSD 3.0, VNC, Nedit/Sylpheed font problem.

12. X-VNC won't start: font problem?

13. Display problem (I think) with VNC Please help!!!