RPM 3.0.4 won't install new packages

RPM 3.0.4 won't install new packages

Post by Jiim McIntyr » Sun, 31 Dec 1899 09:00:00



Hi

I'm using rpm 3.0.4 on rh 6.2. When I try to install or update new
packages, I get the message:
"Only packages with major <= 3 are supported by this version of rpm".
I've never had this problem before. Because of this error, I can't
upgrade rpm itself.  I get the same error message when I try rpm-Uvh
libtool-1.3.5-8.i386.rpm. Same thing for autoconf, and automake.  Anyone
have some idea of what's going on here. TIA

Jim

 
 
 

RPM 3.0.4 won't install new packages

Post by Jean-David Beye » Sun, 31 Dec 1899 09:00:00



> Hi

> I'm using rpm 3.0.4 on rh 6.2. When I try to install or update new
> packages, I get the message:
> "Only packages with major <= 3 are supported by this version of rpm".
> I've never had this problem before. Because of this error, I can't
> upgrade rpm itself.  I get the same error message when I try rpm-Uvh
> libtool-1.3.5-8.i386.rpm. Same thing for autoconf, and automake.  Anyone
> have some idea of what's going on here. TIA

> Jim

Try upgraeding to rpm-3.0.5-9.6x. You should be able to do that. It should
be able to install the next one.

--
 .~.   Jean-David Beyer           Registered Linux User 85642.
 /V\                              Registered Machine    73926.
/( )\  Shrewsbury, New Jersey
^^-^^  4:35pm up 22:14, 3 users, load average: 2.49, 2.46, 2.20