Can't reach the Internet with RedHat 7.2

Can't reach the Internet with RedHat 7.2

Post by Desmond Riv » Mon, 26 Nov 2001 09:04:21



Hi all,

I'm a bit of a newbie here, so my questions may seem very broad.
Please bear with me.

I have a 2 node network at home. One of my computers is a gateway
(node 1), and is connected to the Internet via an ADSL modem. My other
computer is a regular workstation (node 2). I used to have RedHat 7.1
on my workstation, and I was able to surf the Net pretty much out of
the box, after setting everything up properly. By properly, I mean:

- Assign 192.168.0.2 to my workstation
- Assign 192.168.0.1 as my default gateway
- no firwalling rules on my workstation (everything comes through)

This always seemed to work. I know my gateway still works and is able
to access the outside world on it's own.

With RH 7.2, everything on node 2 seems to be down. I've checked my
gateway IP address (in /etc/sysconfig/network) and my eth0 IP address
(I forget where), and they both seemed fine.

From node 2 (my workstation) I can sucessfully ping 127.0.0.1. I
CANNOT telnet to 127.0.0.1 (connection refused) and I CANNOT ping my
gateway (ping 192.168.0.2 returns a host unreachable error). I can't
even ping myself through the ethernet card (ping 192.168.0.1 return
host unreachable error). The card IS up; I checked it with ifconfig.

So, now on to my question: is there anything in RH 7.2 that's somehow
differnt from RH 7.1 that would cause my network services not to work?
Maybe there's some option that's set in RH 7.1 that's not set in RH
7.2, or vice-versa? Or do you think maybe I just made a silly mistake
somewhere and I should be more careful?

Thanks in advance!

Desmond

 
 
 

Can't reach the Internet with RedHat 7.2

Post by Kevin Hay » Mon, 26 Nov 2001 11:37:09



Quote:> Hi all,

> I'm a bit of a newbie here, so my questions may seem very broad.
> Please bear with me.

> I have a 2 node network at home. One of my computers is a gateway
> (node 1), and is connected to the Internet via an ADSL modem. My other
> computer is a regular workstation (node 2). I used to have RedHat 7.1
> on my workstation, and I was able to surf the Net pretty much out of
> the box, after setting everything up properly. By properly, I mean:

> - Assign 192.168.0.2 to my workstation
> - Assign 192.168.0.1 as my default gateway
> - no firwalling rules on my workstation (everything comes through)

> This always seemed to work. I know my gateway still works and is able
> to access the outside world on it's own.

> With RH 7.2, everything on node 2 seems to be down. I've checked my
> gateway IP address (in /etc/sysconfig/network) and my eth0 IP address
> (I forget where), and they both seemed fine.

> From node 2 (my workstation) I can sucessfully ping 127.0.0.1. I
> CANNOT telnet to 127.0.0.1 (connection refused) and I CANNOT ping my
> gateway (ping 192.168.0.2 returns a host unreachable error). I can't
> even ping myself through the ethernet card (ping 192.168.0.1 return
> host unreachable error). The card IS up; I checked it with ifconfig.

> So, now on to my question: is there anything in RH 7.2 that's somehow
> differnt from RH 7.1 that would cause my network services not to work?
> Maybe there's some option that's set in RH 7.1 that's not set in RH
> 7.2, or vice-versa? Or do you think maybe I just made a silly mistake
> somewhere and I should be more careful?

Just this weekend upgraded a Redhat 7.1 partition, and had the same
problem on a similar setup.

Somehow during the upgrade my gateway address got changed from
192.168.0.1 to 192.168.0.254 (as i remember) during the upgrade.
I discovered this from the output of " route -n ", so after changing it in
        /etc/sysconfig/networking/devices/ifcfg-eth0

Rebooted and all was OK...

HTH

Kevin

 
 
 

1. Redhat 7.2, KDE3 and "KLauncher could not be reach via DCOP"

I had been using KDE 2.2 on a Redhat 7.2 for a while. no major
problems. since upgraded to KDE3 a week ago (installed from RPMs, went
well), I got "KLauncher could not be reach via DCOP" a coupe of times
a day when use with VNC, or every other day when use a console.
normally I restart the vncserver and everything is good for a few
hours. another minor problem when it does work, I can't set font to
"Linux" in Konsole, it says "Font
'-misc-console-medium-r-normal--16-160-72-72-c-160-iso10646-1' not
found".

on another freshly install Skipjact beta2, the mouse curser is about
1/4 inch off to right (curser is on the right side of active area,
when I click an items, I have to click 1/4 inch on the right, very
odd)

anyone has fixes? thanks

Dr.J

2. Mitsumi Quad Speed CD-ROM Units

3. Help: Upgrade from Redhat 7.1 to Redhat 7.2 results internet problem

4. DOSEMU: Stealth64

5. NT reaches internet fine; Linux doesn't--what's wrong?

6. Numlock/Capslock on VC's

7. RedHat 7.2 doesn't like my NIC's

8. zip 650 cdwriter

9. How can i do load balancing with 2 Internet connections (redhat 7.2) ?

10. Internet Connection via a Network Shared Connection in RedHat 7.2

11. How to connect to internet through modem in RedHat 7.2

12. RedHat 7.2 as DHCP server & internet connection sharing

13. configuring gcc-2.7.2.x on redhat 7.2