Slackware serial driver and getty (a problem)

Slackware serial driver and getty (a problem)

Post by Gunnar Orvarss » Fri, 19 Jan 1996 04:00:00



We've been using SlackWare 1.1.1 or 1.1.2 (Linux kernel 0.99) on multiple
laptop machines for a couple of years now.  We've used them to connect certain
kind of scales to them through the serial port which has been controlled by
getty.  This way, we've been able to log into the Linux host using a two line
liquid crystal display on the scale and run a specific application while
working with the scale.  This has all worked fine for us.

Now I'm trying to use the same method under Slackware 2.3 (Linux kernel 1.2.8).
This does NOT work.  Somehow we never seem to manage to get getty to work the
way it used to under the older version of Slackware and we can't log in.

Does anyone know what might cause this problem, that we're having?  Are there
any basic differences concerning the serial drivers or getty versions between
these two different releases of Linux Slackware distribution?

Best regards,

--

Hafrannsoknastofnunin/Fiskistofa                 Telephone:   +354 5697909
(Marine Research Inst./Directorate of Fisheries) Fax:         +354 5697990
Ingolfsstraeti 1, Reykjavik, Iceland             Home phone:  +354 5813253

 
 
 

1. Getty problems/Serial problem

Help.  I had getty working on ttyd0.  I could login.  All was well.
I did not use it for about 5 weeks.  It just sat there.  During that
time nothing changed, except for adding NFS.  Now it does not work
anymore.  

The ethernet is on irq 3
sio is in irq 4

I have a null modem, the same null modem that worked before.

The getty process is up.

I see /usr/libexec/getty std.9600 ttyd0

I can cat cuaa0 and see data coming out when I type.

I would appreciate any idea whatever.  It used to work!!!

Thanks,
 Judy

2. Help with Imposition

3. Newbie and problems with getty and serial ports

4. SB Live! / Alsa / MIDI

5. Serial Problems with getty, setserial, etc... (please help)

6. POSIX Semaphore problem

7. Serial GETTY problem

8. test post -- ignore

9. getty/uugetty problems in slackware (BUG REPORT)

10. Getty/Serial problems

11. Serial mouse only works during installation in graphics mode, problem with 'serial device driver'

12. Slackware: XDMCP and Getty problems

13. Getty & serial.c problem