/bin/df doesn't work on RAID disk

/bin/df doesn't work on RAID disk

Post by Rodolph » Sun, 11 Jul 1999 04:00:00



hi,
I've set up 2 scsi disks in an array using RAID 1 (using RedHat 6.0,
kernel 2.2.5-22). I've also recomiled the kernel as I need to have raid
1 built in  in order to boot on the raid array.

The array works fine (as I can see from /proc/mdstat) but df doesn't
give me the disk usage.
It's very annoying ! Does someone encounter this problem ? How can I
solve it ?

TIA,

Rodolphe

 
 
 

/bin/df doesn't work on RAID disk

Post by Paul Colquho » Mon, 12 Jul 1999 04:00:00


|hi,
|I've set up 2 scsi disks in an array using RAID 1 (using RedHat 6.0,
|kernel 2.2.5-22). I've also recomiled the kernel as I need to have raid
|1 built in  in order to boot on the raid array.
|
|The array works fine (as I can see from /proc/mdstat) but df doesn't
|give me the disk usage.
|It's very annoying ! Does someone encounter this problem ? How can I
|solve it ?

Can you post the output ( or error message ) produced by /bin/df ?

The contents of /proc/mdstat , /etc/fstab and /etc/raidtab would
be helpfull as well.

--

Universal Life Church    http://andor.dropbear.id.au/~paulcol
-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-=*=-
xenaphobia: The fear of being beaten to a pulp by
            a leather-clad, New Zealand woman.

 
 
 

1. Questions of total disk required and why df doesn't work

I have 103Mb of disk plus another 12Mb for swap available.  All FAQs I have
read point to about 90Mb for a full install.  However after a full install
I have less thatn 1Mb left on my 103Mb parition!  The current FAQ suggests
80Mb is required.  What the deal?

Everything works fine.  I got the mono X server to work and was attempting
to add the XS3 server when I discovered the space problem.  When I attempted
to use df and it reorted it could not open the mounted partition table.  it
works fine from the A1 boot, but the disk made at the end of the install,
df fails to function.  Anyone run into this?
--

Creek, not creek; pop, not soda; car needs washed...

2. 2 SCSI host adapters on Linux?

3. df doesn't show mounted disk ?!

4. How to set up carrier detect

5. Help: df doesn't work anymore

6. Installing from CDROM on secondary adaptec controller

7. libc 4.3.3 problem: df doesn't work anymore

8. WACOM ArtPad: Pen button functioning as 3rd mouse button

9. df doesn't work

10. Re. bffcreate -X doesn't work Re: bffcreate -X Doesn't Work

11. "df" doesn't work on Solaris 2.3

12. /usr/bin, /usr/local/bin, /sbin or /opt/bin, /var/opt/bin - I'm confused.

13. Makefile doesn't work when SHELL=/bin/sh