xconsole doesn't work

xconsole doesn't work

Post by Mark Fernyhou » Mon, 14 Mar 1994 22:57:15



[ Article crossposted from comp.os.linux.help ]
[ Author was Mark Fernyhough ]
[ Posted on Sat, 12 Mar 1994 17:18:09 GMT ]

I can't get xconsole to work at all. All the messages go to the virtual
console were i started X.
Cany anyone help?

Thanks in advance
Mark

 
 
 

xconsole doesn't work

Post by James D. Levi » Tue, 15 Mar 1994 07:11:32


I have the same problem with xconsole.  After checking permissions on
/dev/console, I gave up.  The easy workaround is-

# xterm -C -name "Console" &

James


crossposted from comp.os.linux.help ] : [ Author was Mark Fernyhough ]
: [ Posted on Sat, 12 Mar 1994 17:18:09 GMT ]

: I can't get xconsole to work at all. All the messages go to the virtual
: console were i started X.
: Cany anyone help?

: Thanks in advance
: Mark

 
 
 

1. cmdtool -C, xconsole: redirection doesn't work

I'd like to ask you to help me solve the following problem:

H: SS1000 without screen/keyboard. VT100 attached via serial port.
S: Solaris 2.4

ioctl SRIOCSREDIR returned -1, attempt to make tty the console failed
(Tty package)

However I can do: date > /dev/console and /dev/console is used by some
processes:

# fuser /dev/console
/dev/console:    12255o   17031o   15450o   29559o   25644o   25251o    
5648o   28296o   28961o     640o     608o    7285o   16537o   24681o    
365o     316o     312o     311o     254o     253o     252o     223o    
218o     211o     162o     158o

truss xconsole shows:

982: stat("/dev/console", 0xDFFFFC20)                 = 0
982: getuid()                                   = 0 [0]
982: access("/dev/console", 6)                        = 0
982: pipe()                                     = 4 [5]
982: open("/dev/console", O_RDONLY)           = 6
982: ioctl(6, 0x1C9E0001, 0x00000004)           Err#22 EINVAL

I assume ioctl is from wscons redirection. wscons (7) states:

     EINVAL         (x86 only) fd does not denote /dev/console.
                    ==========

fd 6 obviously denotes /dev/console. Moreover this is SPARC, not x86.

What could I do to have xconsole working? Any help is appreciated.

Thank you

Maciek Uhlig
Computer Center
Silesian University
Katowice, Poland

2. Got Solaris (Both Sparc & Intel) - need C compiler - want GCC

3. XCONSOLE doesn't work??!!

4. Mystery install procedures

5. No Imake.tmpl file, xconsole doesn't work

6. Help - Simple Null Modem connection

7. xconsole doesn't work

8. What is TurboLinux?

9. xconsole / xterm -C doesn't work

10. Re. bffcreate -X doesn't work Re: bffcreate -X Doesn't Work

11. PPP doesn't die, it just doesn't work anymore

12. : PLIP start up doesn't report problems but also doesn't work?

13. My xconsole doesn't do anything.