ANNOUNCEMENT: v1.0 BETA 1 release of x2600

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Alex Horn » Sat, 23 Mar 1996 04:00:00



ANNOUNCEMENT: v1.0 BETA 1 release of x2600, An Atari 2600 Emulator
==================================================================

x2600 is available for download as source and Linux ELF binaries from
http://www.dcs.warwick.ac.uk/~wilhor/x2600.html

Here is the README from the source distribution. For more information check
the above URL.

x2600 README
============

$Id: README,v 1.1 1996/03/21 17:15:31 alex Exp alex $

Introduction
------------
Welcome to x2600, an Atari 2600 Emulator for UNIX/X systems. You can now
experience all the fun of old 2600 games on your high powered workstation.
Thrill to the blocky graphics! Get headaches from the flicker! Wallow in
nostalgia!

Using the Emulator
------------------
Usage: x2600 [OPTIONS] filename
-rr refreshrate
-ntsc bool

and filename should be either a straight 2k or 4k cartridge dump, or an
Activision Action Pack .bin format file.

e.g. x2600 -rr 3 ~/carts/pacman.vcs

Why?
----
x2600 is the the result on my 3rd year university project. I aimed to preserve
old computer games that would otherwise be lost to the world.

Platforms
---------
I have tested x2600 on my home Linux system and on a Sparc 2 running
SunOS 4.3. If you manage to compile it on another platform please send me an
e-mail.

Performance
-----------
The 2600 is notoriously difficult to emulate, especially in C. So I would
recommend at least a Pentium level processor. The frame buffer speed also
matters.

On a Sparc 2 x2600 is far too slow.
On a Pentium 100 is just nice with frame skipping set to 3.

Better performance will probably come in later releases.

Known Bugs/Limitations
----------------------
Not all games work.
Beware of the file selector, it doesn't always work.
There is no sound support yet.

Copyright
---------
x2600 is free software distributed under the terms of the GNU General Public
License. See the file COPYING for details.

Credits
-------
A full list of contributors can be found in the file CREDITS.

Alex Hornby 21.3.96

--
++ Alex Hornby | Third Year Computer Science | University of Warwick ++
++ http://www.dcs.warwick.ac.uk/~wilhor/ | PGP | Tel (01203) 677624  ++

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by MagerV.. » Mon, 25 Mar 1996 04:00:00


Alex> ANNOUNCEMENT: v1.0 BETA 1 release of x2600, An Atari 2600
Alex> Emulator

yay!

Alex> Platforms --------- I have tested x2600 on my home Linux system
Alex> and on a Sparc 2 running SunOS 4.3. If you manage to compile it
Alex> on another platform please send me an e-mail.

i'm trying to compile under solaris 2.4, but x2600 requires athena and
fwf, we have neither in the system... i found fwf, but not athena... help?
--
    ___     .              +   .       .              .   Per Olofsson
 ._|___|_,       .     .  .         .       . +  .         .      o  

     -     .      .     .   o         +              .     .     .    
     "       +            +    .     http://www.cling.gu.se/~cl3polof/

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Marat Fayzull » Mon, 25 Mar 1996 04:00:00


: ANNOUNCEMENT: v1.0 BETA 1 release of x2600, An Atari 2600 Emulator
: ==================================================================
: x2600 is available for download as source and Linux ELF binaries from
: http://www.dcs.warwick.ac.uk/~wilhor/x2600.html
There is a problem with your emulator: it requires Athena and FWF
widget sets, which are very hard to come by in a standard Unix
environment [they have to be installed]. Is there any chance
to get it running on plain X11, or maybe with Tk widget set?

Marat

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by MIDIBea » Mon, 25 Mar 1996 04:00:00


Is this emulator only for Unix/Linux or is there a DOS version?
--
Seeya

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by James Coop » Tue, 26 Mar 1996 04:00:00




>: ANNOUNCEMENT: v1.0 BETA 1 release of x2600, An Atari 2600 Emulator
>: ==================================================================
>: x2600 is available for download as source and Linux ELF binaries from
>: http://www.dcs.warwick.ac.uk/~wilhor/x2600.html
>There is a problem with your emulator: it requires Athena and FWF
>widget sets, which are very hard to come by in a standard Unix
>environment [they have to be installed]. Is there any chance
>to get it running on plain X11, or maybe with Tk widget set?

Maybe it would even be possible to put a link to the source that can
actually be read by everyone?

Mosaic simply tells me

        Error 403

        Forbidden - by rule

when I click on the "The full source code." link.

(Using UNIX Mosaic 2.7b2 on an HP-UX box.)

--
---------------
Jim Cooper

Any opinions expressed herein are mine (Mine, all mine!  Ha, ha, ha!),
and not necessarily those of my employer.

I'm NOT Politically Correct, but that's because I'm "Sensitivity Challenged."

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Ayal Ryge » Wed, 27 Mar 1996 04:00:00




> : ANNOUNCEMENT: v1.0 BETA 1 release of x2600, An Atari 2600 Emulator
> : x2600 is available for download as source and Linux ELF binaries from
> : http://www.dcs.warwick.ac.uk/~wilhor/x2600.html


so just binaries for that would be great!
I tried the Linux version and it seemed fine.

 There is a problem with your emulator: it requires Athena and FWF
 widget sets, which are very hard to come by in a standard Unix
 environment [they have to be installed].
<

Athena is PD by MIT (I'm pretty sure), and it is readily available
(Linux seems to install it in custom mode).

As for FWF, is that PD? I'm not sure, but Linux versions are
easy to get.

      Is there any chance to get it running on plain X11, or
maybe with Tk widget set?
<

Yes, I got it to work under Linux using XF86 and a Motif clone.
The Tk widget set or even generic XLib should not be too hard.
Want me to try it?

Quote:

> Marat

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Guy D Albertel » Thu, 28 Mar 1996 04:00:00


: >
:       Is there any chance to get it running on plain X11, or
: maybe with Tk widget set?
: <
: Yes, I got it to work under Linux using XF86 and a Motif clone.
: The Tk widget set or even generic XLib should not be too hard.
: Want me to try it?

Plain X11 would be a good Idea but Tk would be WAY too slow, 60fps in an
interpreted language? Yea right.
--
Guy Albertelli II           |  GCS -d+ c++++ l++ h  |     /|       O-  


I would love to but . . .                           |     U  Ack--Phfft!
   having fun gives me *ly heat.

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Marat Fayzull » Thu, 28 Mar 1996 04:00:00



: Plain X11 would be a good Idea but Tk would be WAY too slow, 60fps in an
: interpreted language? Yea right.
We are talking about GUI only
 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Marat Fayzull » Thu, 28 Mar 1996 04:00:00


: Yes, I got it to work under Linux using XF86 and a Motif clone.
: The Tk widget set or even generic XLib should not be too hard.
: Want me to try it?
Yes, Tk would be great as just about any system in existence has it.
I just don't want to install Athena and WFW solely for the x2600,
and many people probably feel the same way.

Marat

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by MagerV.. » Thu, 28 Mar 1996 04:00:00



Guy> or : maybe with Tk widget set? : < : Yes, I got it to work under
Guy> Linux using XF86 and a Motif clone. : The Tk widget set or even
Guy> generic XLib should not be too hard. : Want me to try it?

Guy> Plain X11 would be a good Idea but Tk would be WAY too slow,
Guy> 60fps in an interpreted language? Yea right.

60fps file requestor?
--
    ___     .              +   .       .              .   Per Olofsson
 ._|___|_,       .     .  .         .       . +  .         .      o  

     -     .      .     .   o         +              .     .     .    
     "       +            +    .     http://www.cling.gu.se/~cl3polof/

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by MagerV.. » Thu, 28 Mar 1996 04:00:00


Ayal> Yes, I got it to work under Linux using XF86 and a Motif clone.
Ayal> The Tk widget set or even generic XLib should not be too hard.
Ayal> Want me to try it?

Marat> Yes, Tk would be great as just about any system in existence
Marat> has it. I just don't want to install Athena and WFW solely for
Marat> the x2600, and many people probably feel the same way.

yes! fwf was a pain in the ass,
--
    ___     .              +   .       .              .   Per Olofsson
 ._|___|_,       .     .  .         .       . +  .         .      o  

     -     .      .     .   o         +              .     .     .    
     "       +            +    .     http://www.cling.gu.se/~cl3polof/

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Jacob C Kesing » Fri, 29 Mar 1996 04:00:00




>Yes, Tk would be great as just about any system in existence has it.
>I just don't want to install Athena and WFW solely for the x2600,
>and many people probably feel the same way.

By ``Athena'', do people mean the Xaw library?  If so, I would think
that would be a heck of a lot more prevalent than Tk.

  ==Jake

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Guy D Albertel » Fri, 29 Mar 1996 04:00:00




: Guy> or : maybe with Tk widget set? : < : Yes, I got it to work under
: Guy> Linux using XF86 and a Motif clone. : The Tk widget set or even
: Guy> generic XLib should not be too hard. : Want me to try it?
:
: Guy> Plain X11 would be a good Idea but Tk would be WAY too slow,
: Guy> 60fps in an interpreted language? Yea right.
:
: 60fps file requestor?

No, the fwf widget being used is the Canvas widget to draw the actual
graphics from the game on. To replace the fwf Canvas with the Canvas
from the Tk widget set would cause a huge dent in the performance.

As for replacing the other widgets with Tk, sure, might look better to,
since Xaw is nothing to write home about, but the graphics region would
be better suited to lowlevel X11 routines.

Enjoy.
--
Guy Albertelli II           |  GCS -d+ c++++ l++ h  |     /|       O-  


I would love to but . . .                           |     U  Ack--Phfft!
   I'm attending a perfume convention as guest sniffer.

 
 
 

ANNOUNCEMENT: v1.0 BETA 1 release of x2600

Post by Guy D Albertel » Fri, 29 Mar 1996 04:00:00



: : Plain X11 would be a good Idea but Tk would be WAY too slow, 60fps in an
: : interpreted language? Yea right.
: We are talking about GUI only

I know, but the main complaint is fwf, which is being used for the graphics to
be drawn in, replacing the fwf stuff with Tk would be hideously slow, for the
other parts of the system, fine.

--
Guy Albertelli II           |  GCS -d+ c++++ l++ h  |     /|       O-  


I would love to but . . .                           |     U  Ack--Phfft!
   my bathroom tiles need grouting.

 
 
 

1. ANNOUNCE Virtual 2600 (formerly x2600) Beta 2 release.

ANNOUNCE Virtual 2600 (formerly x2600) Beta 2 release.
------------------------------------------------------

Virtual 2600 is a GPLed emulation of the classic Atari 2600 console
running on a X11/SVGAlib/Linux and other *NIX/X11 platforms.

Feature introduced since beta 1:

+ Pure tone sound implementation using NAS.
+ New GNU autoconf ./configure style setup.
+ No longer needs the FWF widget set to run.
+ Support for new Common 2600 file format.
+ PC Joystick support.
+ Dynamic resizing under X11.
+ Atari 8k/16k bank switching.
+ Paddle emulation.
+ More speed.

Bug Fixes since beta 1:

+ Should compile more cleanly on more machines.
+ Various emulation bugs. More stuff should work now.

For more information, sources and Linux binaries see:

http://www.users.zetnet.co.uk/ahornby/v2600.html

--
++ Alex Hornby | http://www.users.zetnet.co.uk/ahornby | PGP ++

2. dadmin and options

3. ANNOUNCEMENT: Evil Purple NewsCache v1.0.05 Beta

4. Installing Staroffice

5. V1.3 kernel release announcements?

6. 3Com 905 TX driver

7. SNIPS v1.1 (NOCOL) Release Announcement

8. Linux-Hardware Digest #249

9. Edith V1.32 final beta release

10. SATAN v1.1.1 [released] and v1.1.4 [experimental] both do not compile on Redhat 6.0.

11. Announcement: New beta of apcupsd daemon

12. xmove 2.0 beta announcement -- 16 and 24-bit display support

13. Announcement - Beta Test beginning for Developers' Toolkit Supple ment V5.1A