System won't recognize mouse.

System won't recognize mouse.

Post by Chang Li » Tue, 21 Sep 1999 04:00:00



My mouse won't be recognized either in text or graphics mode. I have both
SuSE6.2 & RH6.0 installed, plus Win98. In win98 mouse works ok, and mouse
works ok with linux until last night. What I did was to recomple SuSE
kernel in order to support my sound card, after reboot I found mouse
didn't work. I have tried many times without success. Funny thing is,
when I switched to RH6.0, mouse didn't work either. I don't think I have
done anything to RH.

Does anybody have idea what could be the problem? Any input is
appreciated.

 
 
 

System won't recognize mouse.

Post by John G. Sandel » Tue, 21 Sep 1999 04:00:00



> My mouse won't be recognized either in text or graphics mode. I have both
> SuSE6.2 & RH6.0 installed, plus Win98. In win98 mouse works ok, and mouse
> works ok with linux until last night. What I did was to recomple SuSE
> kernel in order to support my sound card, after reboot I found mouse
> didn't work. I have tried many times without success. Funny thing is,
> when I switched to RH6.0, mouse didn't work either. I don't think I have
> done anything to RH.

> Does anybody have idea what could be the problem? Any input is
> appreciated.

Is it a serial mouse or PS/2? Did you by an chance turn it off in the
process of configuring your new kernel? If so, run make config again. If
you have a PS/2 mouse, you need to say Y to mouse support (not serial
mice). If you have a serial mouse say N to mouse support (not serial
mice). Recompile, rerun /sbin/lilo (if you're using LILO).

Hope this helps. I moved a hard drive from an old computer (serialmouse)
to a new one (PS/2 mouse) and forgot about the mouse difference,
couldn't use the mouse. Took me a while to realize what was going on...

John Sandell

 
 
 

System won't recognize mouse.

Post by Chang Li » Wed, 22 Sep 1999 04:00:00


Thanks for your post. I have tried both, but neither works. What confused
me the most is, why RH is also affected? Doing anything(just recompile
kernel and run lilo) in SuSE shouldn't affect the other distribution,
right?

Any idea?



> > My mouse won't be recognized either in text or graphics mode. I have both
> > SuSE6.2 & RH6.0 installed, plus Win98. In win98 mouse works ok, and mouse
> > works ok with linux until last night. What I did was to recomple SuSE
> > kernel in order to support my sound card, after reboot I found mouse
> > didn't work. I have tried many times without success. Funny thing is,
> > when I switched to RH6.0, mouse didn't work either. I don't think I have
> > done anything to RH.

> > Does anybody have idea what could be the problem? Any input is
> > appreciated.

> Is it a serial mouse or PS/2? Did you by an chance turn it off in the
> process of configuring your new kernel? If so, run make config again. If
> you have a PS/2 mouse, you need to say Y to mouse support (not serial
> mice). If you have a serial mouse say N to mouse support (not serial
> mice). Recompile, rerun /sbin/lilo (if you're using LILO).

> Hope this helps. I moved a hard drive from an old computer (serialmouse)
> to a new one (PS/2 mouse) and forgot about the mouse difference,
> couldn't use the mouse. Took me a while to realize what was going on...

> John Sandell

 
 
 

System won't recognize mouse.

Post by Jayan » Thu, 23 Sep 1999 04:00:00


plug and pray..?
Try resetting your pnp configuration info in the bios....

in win98, does the mouse still work, or is that it used to, earlier?
Check if the mouse is plugged in properly.. maybe it came loose when
you reached over to pick that beer can, while the make bzImage was
going on.. :-)

Jayan


> Thanks for your post. I have tried both, but neither works. What confused
> me the most is, why RH is also affected? Doing anything(just recompile
> kernel and run lilo) in SuSE shouldn't affect the other distribution,
> right?

> Any idea?



> > > My mouse won't be recognized either in text or graphics mode. I have both
> > > SuSE6.2 & RH6.0 installed, plus Win98. In win98 mouse works ok, and mouse
> > > works ok with linux until last night. What I did was to recomple SuSE
> > > kernel in order to support my sound card, after reboot I found mouse
> > > didn't work. I have tried many times without success. Funny thing is,
> > > when I switched to RH6.0, mouse didn't work either. I don't think I have
> > > done anything to RH.

> > > Does anybody have idea what could be the problem? Any input is
> > > appreciated.

> > Is it a serial mouse or PS/2? Did you by an chance turn it off in the
> > process of configuring your new kernel? If so, run make config again. If
> > you have a PS/2 mouse, you need to say Y to mouse support (not serial
> > mice). If you have a serial mouse say N to mouse support (not serial
> > mice). Recompile, rerun /sbin/lilo (if you're using LILO).

> > Hope this helps. I moved a hard drive from an old computer (serialmouse)
> > to a new one (PS/2 mouse) and forgot about the mouse difference,
> > couldn't use the mouse. Took me a while to realize what was going on...

> > John Sandell

 
 
 

1. 3-button *Optical* Mouse Systems Mouse in X Won't Configure Properly

3-button *Optical* MouseSystems Mouse in X Won't Configure Properly

I just purchased a 3-button *Optical* Mouse and I can't get the
middle button to work properly in X.  The Mouse Systems protocol
does not work at all.  When I move the mouse around a little,
everything gets all messed up, the pointer jumps around, and
menus flash.  I tried all combinations of ClearRTS and Clear DTR
and Emulate3Buttons and Chordmiddle.  I have tried just about
every possible configuration, and the most success I have is
with the Microsoft Protocol.  However, when I *click* the middle button,
the mouse acts as if the first button is being held down for
about half a second.  Emulate3Buttons works when buttons 1 and 3
are depressed, but I specifically bought this mouse so I can
have three buttons.

The actually mouse works perfectly fine in text mode with
"gpm -t ms"--this is the bare Microsoft protocol, not the
standard one.

Does anyone out there have one of these mice, or can someone
please offer some ideas?

Please respond to this account.

Thanks,
Ken

2. Which is more reliable, QIC or DAT?

3. Logi.Mouse won't move, but is recognized.

4. Download Oracle for Intel Solaris

5. X won't recognize mouse plugged into PS/2 port

6. HP Deskjet 712c

7. Slack 7.1 won't recognize PS2 mouse

8. WU-FTP 2.6: PAM can't open pam.conf?! HELP!!!!

9. XWindows won't recognize my mouse

10. System recognizes CompactFlash card but won't mount it

11. HELP - SYSTEM WON'T RECOGNIZE PASSWORD AFTER CHANGES HAVE BEEN MADE

12. BUSMICE old logitech trackman, system won't recognize

13. HELP: system won't recognize PAS16 clone