GCC-UPgrade-mini-HowTo [FINAL 4-12-96]

GCC-UPgrade-mini-HowTo [FINAL 4-12-96]

Post by Kent Robot » Wed, 10 Apr 1996 04:00:00



GCC-UPgrade-mini.HowTo "Trust this, and move into the future." (Kent Robotti)

(Upgrading gcc, libc, binutils, ld, make, ?...)

(Packages, you will need...)
(1). gcc.2.7.2?.bin.tar.gz            <-The gcc (c) compiler...)
(2). bin86-03.tar.gz                  <-May have, check /usr/bin ld86 & as86...)
(3). binutils-2.6.0.12?.bin.tar.gz    <-The latest ? as of this writing...)
(4). libc.5.3.9?.bin.tar.gz           <-C Libraries.>    
(5). ld.so-1.7.14?.tar.gz             <-The dynamic linker and loader..)      
(6). make-3.74-direntfix-elf.tar.gz   <-Binary-elf version, of make, that fixes
(7). Optional ? (see below...)          a bug, (No rule to make target..) you
                                        might experience, after the upgrade...)
(Where to get...)                          
ncftp> open                          
to> ftp.cc.gatech.edu                
ncftp> cd /pub/Linux/GCC              <-For packages 1-4...)
ncftp> ls
ncftp> get packages 1-4
ncftp> cd ..                          <-Go back one directory...)
ncftp> cd devel/make                  <-For make, /pub/Linux/devel/make)
ncftp> ls
ncftp> get make
ncftp> quit

If the directory contents scroll by, to quickly to see, try ls -r
to display them in reverse, or ls | more (one screenfull at a time,
press q to quit. (ls | more, might not work, depends on ?)

(Now move all the packages, to / )
?/upgrade# mv *gz /                      <-This will move all to / )
?/upgrade# cd /
/# tar xzvf gcc.2.7.2?.bin.tar.gz        <-Begin unpacking, one at a time...)
/# Next binutils
/# Next libc
/# tar xzvf make-3.74-direntfix-elf.tgz  <-Unpack and install make...)
/# cd *elf
/make-3.74-bin-elf# mv make /usr/bin     <-Move (make-fixed) to /usr/bin,
                                           overwriting old make...)
/# tar xzvf ld.so-1.7.14.tar.gz          <-Unpack ld...)  
/# cd *14
/ld.so-1.7.14# instldso.sh               <-Install ld...)

(Now of course, you can remove all the packages...)
/# rm *tar.gz     <-Be sure there's nothing else, in the same dir. with
                    the same extension tar.gz, that you want to keep.>
/# rm -r *elf     <-To remove make.)
/# rm -r *14      <-To remove ld.)

(Cleaning up...)

(To remove m68k and sparc directories...What's That..?)

?/# cd /usr
usr/# rm -rf m68k-linux m68k-linuxaout sparc-sun-solaris2 sparc-sun-sunos4.1

(To remove the old 2.7.0 directories...)

/# rm -rf /usr/lib/gcc-lib/1486-linux/2.7.0
/# rm -rf /usr/lib/gcc-lib/i486-linuxaout/2.7.0

(Linking up...)

/# cd /lib
/lib# ln -sf /usr/lib/gcc-lib/i486-linux/2.7.2/cpp cpp   <-Create new link
/lib# ldconfig -v                                          for cpp, to point  
                                                           to 2.7.2/cpp)

(If your useing slackware, you can use pkgtool, to remove three of these
packages, before you unpack the new ones, (Don't remove ldso...) just
the three below...Allso in /usr/bin (ld86 and as86) copy these to /, then
put them back in /usr/bin, after your through useing pkgtool to
remove the packages below, you,ll need (as86 and ld86) to compile the kernel...)

~/# pkgtool
(Chose <Remove> from the menu, this will take ? BogoMipSeconds...)
[x] binutils
[x] gcc270        <-Press the space bar to tag them [x] then <Enter>)
[x] libc          <-Be sure only these three are tagged [x]...)

(Optional packages ?) While your in the neighborhood, try and pick up these  
packages allso, they replace Important programs, that allmost certainly won't
work anymore, after the upgrade, Yea! but, aren't things supposed to work
better..?)

(ftp.cc.gatech.edu)
/pub/Linux/system/Status/ps           <-Don't try to compile, just install...)
(procps-0.99a?.tgz)                   <-do_install                  

(http://www.pi.se/blox)
On this site...
Linux module support utilities...
(modules-1.3.69f?.tar.gz)             <-make and make install...)

fi

(4-12-1996-FINAL)

 
 
 

GCC-UPgrade-mini-HowTo [FINAL 4-12-96]

Post by Kent Robot » Wed, 10 Apr 1996 04:00:00


GCC-UPgrade-mini.HowTo "Trust this, and move into the future." (Kent Robotti)

(Upgrading gcc, libc, binutils, ld, make, ?...)

(Packages, you will need...)
(1). gcc.2.7.2?.bin.tar.gz            <-The gcc (c) compiler...)
(2). bin86-03.tar.gz                  <-May have, check /usr/bin ld86 & as86...)
(3). binutils-2.6.0.12?.bin.tar.gz    <-The latest ? as of this writing...)
(4). libc.5.3.9?.bin.tar.gz           <-C Libraries.>    
(5). ld.so-1.7.14?.tar.gz             <-The dynamic linker and loader..)      
(6). make-3.74-direntfix-elf.tar.gz   <-Binary-elf version, of make,
that fixes
(7). Optional ? (see below...)          a bug, (No rule to make target..) you
                                        might experience, after the upgrade...)
(Where to get...)                          
ncftp> open                          
to> ftp.cc.gatech.edu                
ncftp> cd /pub/Linux/GCC              <-For packages 1-5...)
ncftp> ls
ncftp> get packages 1-4
ncftp> cd ..                          <-Go back one directory...)
ncftp> cd devel/make                  <-For make, /pub/Linux/devel/make)
ncftp> ls
ncftp> get make
ncftp> quit

If the directory contents scroll by, to quickly to see, try ls -r
to display them in reverse, or ls | more (one screenfull at a time,
press q to quit. (ls | more, might not work, depends on ?)

(Now move all the packages, to / )
?/upgrade# mv *gz /                      <-This will move all to / )
?/upgrade# cd /
/# tar xzvf gcc.2.7.2?.bin.tar.gz        <-Begin unpacking, one at a time...)
/# Next binutils
/# Next libc
/# tar xzvf make-3.74-direntfix-elf.tgz  <-Unpack and install make...)
/# cd *elf
/make-3.74-bin-elf# mv make /usr/bin     <-Move (make-fixed) to /usr/bin,
                                           overwriting old make...)
/# tar xzvf ld.so-1.7.14.tar.gz          <-Unpack ld...)  
/# cd *14
/ld.so-1.7.14# instldso.sh               <-Install ld...)
             # cd /
/# Now bin86-03.tar.gz   <-If you don't have, Unpack, make, make install...>

(Now of course, you can remove all the packages...)
/# rm *tar.gz     <-Be sure there's nothing else, in the same dir. with
                    the same extension tar.gz, that you want to keep.>
/# rm -r *elf     <-To remove make.)
/# rm -r *14      <-To remove ld.)
/# rm -r *03      <-To remove bin86.)

(Cleaning up...)

(To remove m68k and sparc directories...What's That..?)

?/# cd /usr
usr/# rm -rf m68k-linux m68k-linuxaout sparc-sun-solaris2 sparc-sun-sunos4.1

(To remove the old 2.7.0 directories...)

/# rm -rf /usr/lib/gcc-lib/1486-linux/2.7.0
/# rm -rf /usr/lib/gcc-lib/i486-linuxaout/2.7.0

(Linking up...)

/# cd /lib
/lib# ln -sf /usr/lib/gcc-lib/i486-linux/2.7.2/cpp cpp   <-Create new link
/lib# ldconfig -v                                          for cpp, to point  
                                                           to 2.7.2/cpp)

(If your useing slackware, you can use pkgtool, to remove three of these
packages, before you unpack the new ones, (Don't remove ldso...) just
the three below...Allso in /usr/bin (ld86 and as86) copy these to /, then
put them back in /usr/bin, after your through useing pkgtool to
remove the packages below, you,ll need (as86 and ld86) to compile the kernel...)

~/# pkgtool
(Chose <Remove> from the menu, this will take ? BogoMipSeconds...)
[x] binutils
[x] gcc270        <-Press the space bar to tag them [x] then <Enter>)
[x] libc          <-Be sure only these three are tagged [x]...)

(Optional packages ?) While your in the neighborhood, try and pick up these  
packages allso, they replace Important programs, that allmost certainly won't
work anymore, after the upgrade, Yea! but, aren't things supposed to work
better..?)

(ftp.cc.gatech.edu)
/pub/Linux/system/Status/ps           <-Don't try to compile, just install...)
(procps-0.99a?.tgz)                   <-do_install)                  

(http://www.pi.se/blox)
On this site...
Linux module support utilities...
(modules-1.3.69f?.tar.gz)             <-make and make install...)

fi

(4-12-1996-FINAL)

 
 
 

GCC-UPgrade-mini-HowTo [FINAL 4-12-96]

Post by Kent Robot » Wed, 10 Apr 1996 04:00:00


GCC-UPgrade-mini.HowTo "Trust this, and move into the future." (Kent Robotti)

(Upgrading gcc, libc, binutils, ld, make, ?...)

(Packages, you will need...)
(1). gcc.2.7.2?.bin.tar.gz            <-The gcc (c) compiler...)
(2). bin86-03.tar.gz                  <-May have, check /usr/bin ld86 & as86...)
(3). binutils-2.6.0.12?.bin.tar.gz    <-The latest ? as of this writing...)
(4). libc.5.3.9?.bin.tar.gz           <-C Libraries.>    
(5). ld.so-1.7.14?.tar.gz             <-The dynamic linker and loader..)      
(6). make-3.74-direntfix-elf.tar.gz   <-Binary-elf version, of make, that fixes
(7). Optional ? (see below...)          a bug, (No rule to make target..) you
                                        might experience, after the upgrade...)
(Where to get...)                          
ncftp> open                          
to> ftp.cc.gatech.edu                
ncftp> cd /pub/Linux/GCC              <-For packages 1-5...)
ncftp> ls
ncftp> get packages 1-4
ncftp> cd ..                          <-Go back one directory...)
ncftp> cd devel/make                  <-For make, /pub/Linux/devel/make)
ncftp> ls
ncftp> get make
ncftp> quit

If the directory contents scroll by, to quickly to see, try ls -r
to display them in reverse, or ls | more (one screenfull at a time,
press q to quit. (ls | more, might not work, depends on ?)

(Now move all the packages, to / )
?/upgrade# mv *gz /                      <-This will move all to / )
?/upgrade# cd /
/# tar xzvf gcc.2.7.2?.bin.tar.gz        <-Begin unpacking, one at a time...)
/# Next binutils
/# Next libc
/# tar xzvf make-3.74-direntfix-elf.tgz  <-Unpack and install make...)
/# cd *elf
/make-3.74-bin-elf# mv make /usr/bin     <-Move (make-fixed) to /usr/bin,
                                           overwriting old make...)
/# tar xzvf ld.so-1.7.14.tar.gz          <-Unpack ld...)  
/# cd *14
/ld.so-1.7.14# instldso.sh               <-Install ld...)
             # cd /
/# Now bin86-03.tar.gz   <-If you don't have, Unpack, make, make install...>

(Now of course, you can remove all the packages...)
/# rm *tar.gz     <-Be sure there's nothing else, in the same dir. with
                    the same extension tar.gz, that you want to keep.>
/# rm -r *elf     <-To remove make.)
/# rm -r *14      <-To remove ld.)
/# rm -r *03      <-To remove bin86.)

(Cleaning up...)

(To remove m68k and sparc directories...What's That..?)

?/# cd /usr
usr/# rm -rf m68k-linux m68k-linuxaout sparc-sun-solaris2 sparc-sun-sunos4.1

(To remove the old 2.7.0 directories...)

/# rm -rf /usr/lib/gcc-lib/1486-linux/2.7.0
/# rm -rf /usr/lib/gcc-lib/i486-linuxaout/2.7.0

(Linking up...)

/# cd /lib
/lib# ln -sf /usr/lib/gcc-lib/i486-linux/2.7.2/cpp cpp   <-Create new link
/lib# ldconfig -v                                          for cpp, to point  
                                                           to 2.7.2/cpp)

(If your useing slackware, you can use pkgtool, to remove three of these
packages, before you unpack the new ones, (Don't remove ldso...) just
the three below...Allso in /usr/bin (ld86 and as86) copy these to /, then
put them back in /usr/bin, after your through useing pkgtool to
remove the packages below, you,ll need (as86 and ld86) to compile the kernel...)

~/# pkgtool
(Chose <Remove> from the menu, this will take ? BogoMipSeconds...)
[x] binutils
[x] gcc270        <-Press the space bar to tag them [x] then <Enter>)
[x] libc          <-Be sure only these three are tagged [x]...)

(Optional packages ?) While your in the neighborhood, try and pick up these  
packages allso, they replace Important programs, that allmost certainly won't
work anymore, after the upgrade, Yea! but, aren't things supposed to work
better..?)

(ftp.cc.gatech.edu)
/pub/Linux/system/Status/ps           <-Don't try to compile, just install...)
(procps-0.99a?.tgz)                   <-do_install)                  

(http://www.pi.se/blox)
On this site...
Linux module support utilities...
(modules-1.3.69f?.tar.gz)             <-make and make install...)

fi

(4-12-1996-FINAL)