ide cdrom and cdrom writer with scsi harddisk using cdrecord can't find cd reader

ide cdrom and cdrom writer with scsi harddisk using cdrecord can't find cd reader

Post by Pat Patto » Sun, 31 Dec 1899 09:00:00



I have a scsi controller with the primary harddisk (id 0) and 2 ide cdrom
drives. When using xcdroast (cdrecord) it only shows the cd recorder and not
the other ide cdrom. Loaded modules are scsi-ide and sg. The system shows
both drives found and the cd writer is assigned a scsi device, but xcdroast
does not show the reader.
 
 
 

ide cdrom and cdrom writer with scsi harddisk using cdrecord can't find cd reader

Post by Mike Steven » Sun, 12 Nov 2000 14:15:29


The IDE drive needs to be handled by the ide-scsi driver.  Add something
like append="hdx=ide-scsi" to /etc/lilo.conf.  See the CD-Writing-HOWTO
for more detail.  It worked for me, but YMMV.

--
-Mike Stevens
What manner of quandry is this? - The Tick



Quote:> I have a scsi controller with the primary harddisk (id 0) and 2 ide
cdrom
> drives. When using xcdroast (cdrecord) it only shows the cd recorder
and not
> the other ide cdrom. Loaded modules are scsi-ide and sg. The system
shows
> both drives found and the cd writer is assigned a scsi device, but
xcdroast
> does not show the reader.

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

1. cdrecord can't find driver but OS can read from SCSI CDROM

I have always been able to burn CDs in Linux using an Initio 9100U
SCSI PCI card and a SCSI Yamaha CDW6416S drive, until I installed
Mandrake 8.1.

I also have an IDE Hitachi DVD-ROM GD-5000 which works fine.

Now I can mount the drive and read CDs OK but cdrecord sulks. If I
do...

Cdrecord 1.10 (i586-mandrake-linux-gnu) Copyright (C) 1995-2001 J?rg
Schilling
cdrecord: No such file or directory. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.

If I do an lsmod I get the following related drivers...
initio                 19356   0
sd_mod                 11572   0  (unused)
scsi_mod               91804   3  [sr_mod initio sd_mod]

Out of dmesg I get...
i91u: PCI Base=0xD400, IRQ=9, BIOS=0xFF000, SCSI ID=7
i91u: Reset SCSI Bus ...
scsi0 : Initio INI-9X00U/UW SCSI device driver; Revision: 1.03g
  Vendor: YAMAHA    Model: CRW6416S          Rev: 1.0b
  Type:   CD-ROM                             ANSI SCSI revision: 02

Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 16x/16x writer cd/rw xa/form2 cdda tray
devfs: devfs_register(): device already registered: "cd"
devfs: devfs_register(): device already registered: "cdrom1"
sr0: CDROM not ready.  Make sure there is a disc in the drive.
cdrom: open failed.
Device not ready.  Make sure there is a disc in the drive.

I am unclear if all the error messages above are simply because there
is no disk in the drive. I know some of them are due to this which I
can ignore.

Finally, I can scan the bus with KLinuxSCSIManager and the drive shows
up on 0,0,0 as it should do. So what is CDRecord's big problem?

What should I be looking for here?

Regards,
Fred.

2. SVGALIB, C++ destructors, signals and general peculiarities...

3. kernel doesn't find CDROM on ide-scsi (or does it?)

4. Move from INN to DNEWS

5. Using IDE CD-Writer via ide-scsi?

6. Firewall and IPSec

7. PROBLEM: 2.4.20 on ICH4 : ide-cdrom/ide-scsi problems reading cds

8. Connectix 101c

9. Atapi cdrom problem: wrong speed found by ide-cdrom

10. ide cdrom causes sound probs, whereas scsi cd doesn't!

11. SCSI / IDE cdrom writer problems

12. Warning: Probable kernel bug with ide-scsi mode CDROM drives: readers and burners

13. Linux can't find SCSI CDRom unless booting off CD