1.3.99 Kernel Problem

1.3.99 Kernel Problem

Post by Jeffrey Stewa » Thu, 06 Jun 1996 04:00:00



I have Redhat 3.0.3 and am using 1.3.99 I downloaded from gatech, as
wells as the newest SysVinit, and everything appears normal upon
bootup except for 2 messages

(1) an "unable to open /proc" command line when attempting to start
the httpd daemon, and
(2) a "1.2.13 symbols don't match 1.3.99" when attempting to start
iBSD (i think that's what its called)

even though I recompiled the kernel with the module flag set
correctly.  Does anyone have any ideas?

Thanks
Jeff

 
 
 

1.3.99 Kernel Problem

Post by Randy You » Thu, 06 Jun 1996 04:00:00



>(1) an "unable to open /proc" command line when attempting to start
>the httpd daemon, and
>(2) a "1.2.13 symbols don't match 1.3.99" when attempting to start
>iBSD (i think that's what its called)

>even though I recompiled the kernel with the module flag set
>correctly.  Does anyone have any ideas?

Read the file /usr/src/linux/Documentation and you'll get info on all this.
You need to get some other updates in order to work properly, and each
time you update your kernel you have to recompile the iBCS with that
setup so it will identify correctly.  That one isn't too well covered
in the docs, but the error message is the clue there.

Here is the info on /proc:

Procps utilities
================

   In the latest 1.3.x kernel releases the /proc file system structure
was changed, so you need to upgrade the procps package to version
0.99a.  In the very latest kernels, /proc has changed again.  There's
not yet an officially updated version of procps, so use 0.99a; you
might want to look for one of the patches floating around to update
0.99a for use with 1.3.94 and later kernels.

and here it is on iBCS:

   For a version of iBCS that works with 1.3.x kernels, grab
ftp://tsx-11.mit.edu/pub/linux/BETA/ibcs2/ibcs-1.3-960404-ALPHA.tar.gz

--
Randy Young

Speaking strictly for myself!

 
 
 

1. HELP--->1.3.99 Kernel and PPP Problems

I'm new to Linux and I recently tried to install the 1.3.99 kernel
version for my work.  After reading through the make config help and
what I think was carefully answering all the questions I am still
having problems.  When I reboot now I get the following messages:

Mounting remote file systems...
Starting daemons: syslogd klogd portmap inetd lpd mountdfcntl_setlk()
called
by process 73 with broken flock() emulation
 nfsdfcntl_setlk() called by process 75 with broken flock() emulation

Starting sendmail daemon (/usr/sbin/sendmail -bd -q 15m)...
Loading 8x16 font from file /usr/lib/kbd/consolefonts/t.fnt
Running gpm...
fcntl_setlk() called by process 88 with broken flock() emulation
fcntl_setlk() called by process 91 with broken flock() emulation
fcntl_setlk() called by process 87 with broken flock() emulation

I have no idea what this means so if someone could PLEASE email me at

Also I installed PPP yet when I attempt to run pppd on my machine I
get the msg: Sorry - PPP is not available on this system.  Is PPP only
available through modules or something?  If so how do you install them
and what modules do I need?

Thanks for the help, hopefully I can get this fixed soon.

Jonathan

2. User group in Western Australia ?

3. kernel 1.3.99 and NexGen detectiong problems, please help...

4. Need help getting Wyse Serial "Pods" working under Linux

5. Help: IP_MASQUERADING doesn't work with Kernel 1.3.99

6. Determining terminal is on AS/400

7. Using UFS with 1.3.99 kernel

8. ApacheCon 2001 Europe: CANCELLED

9. PPP with kernel 1.3.99 + 100 -> unknown device

10. ppp and kernel 1.3.99

11. Kernel 1.3.99, cp hangs completly with broken floppy-disk

12. Kernel Change Summary 1.3.99

13. Big problems with 1.3.99, everything OK vith .98