RedHat 9 'less' does not display 8-bit chars

RedHat 9 'less' does not display 8-bit chars

Post by Michal Szymans » Fri, 16 May 2003 21:11:31



Hi,

I've recently upgraded RH from 7.2 to 9.0. It comes with 'less' pager
version "378+iso254". Unfortunately, it does not display my polish
"accented" 8-bit characters anymore. I use xterm terminal with
iso-8859-2 font (of course :) and have LESSCHARSET=latin1. This setup
was working just fine in 7.2. And now it displays '&' for every 8-bit
character in the file. I've downloaded 'less' binary from a RH 7.2
machine - works fine, as always (it is version  358+iso248).

Any hints what could be wrong here?

regards, Michal.

--

  Warsaw University Observatory, Warszawa, POLAND

 
 
 

1. PPP: 'Receive serial link is not 8-bit clean' - what's it mean?

Hello,

I wasnt able to get PPP going over the weekend, but today my
Teach Yourself Linux in 24 Hours book arrived in the mail, and
I did some script tweaking.  I should have copied the scripts I am using
to include with the info below, but its late, I must sleep! :)

I run my etc/ppp/ppp-on script and the thing dials and connects, but
the eventually hangs up.  The pertinent part of the /var/log/messages file
is as follows:

Nov 23 23:38:25 mach3 chat[566]: send (*myusername*^M)
Nov 23 23:38:26 mach3 chat[566]: expect (Password:)
Nov 23 23:38:26 mach3 chat[566]:  *myusername*
Nov 23 23:38:26 mach3 chat[566]: ^MPlease hold ...^M
Nov 23 23:38:26 mach3 chat[566]: ^MPassword:
Nov 23 23:38:26 mach3 chat[566]:  -- got it
Nov 23 23:38:26 mach3 chat[566]: send (*mypassword*^M)
Nov 23 23:38:26 mach3 pppd[565]: Serial connection established.
Nov 23 23:38:27 mach3 pppd[565]: Using interface ppp0
Nov 23 23:38:27 mach3 pppd[565]: Connect: ppp0 <--> /dev/modem
Nov 23 23:38:50 mach3 kernel: Swansea University Computer Society IPX 0.34
for NET3.035
Nov 23 23:38:50 mach3 kernel: IPX Portions Copyright (c) 1995 Caldera, Inc.
Nov 23 23:38:50 mach3 kernel: Appletalk 0.17 for Linux NET3.035
Nov 23 23:38:57 mach3 pppd[565]: LCP: timeout sending Config-Requests
Nov 23 23:38:57 mach3 pppd[565]: Connection terminated.
Nov 23 23:38:57 mach3 pppd[565]: Receive serial link is not 8-bit clean:
Nov 23 23:38:57 mach3 pppd[565]: Problem: all had bit 7 set to 0
Nov 23 23:38:58 mach3 pppd[565]: Hangup (SIGHUP)
Nov 23 23:38:58 mach3 pppd[565]: Exit.
Nov 23 23:40:50 mach3 kernel: PPP: ppp line discipline successfully
unregistered

Does anyone have any idea what the serial link problem referred to is?
Im using redhat 5.1.

So close and yet so far....

Thanks,
Ken Howells

2. ScoMail

3. pppd and 'not 8-Bit clean'

4. Compilation of modutils-2.1.121

5. Don't know how to set terminal 'dumb' to 8-bit...

6. Using Popper for users not in domain?

7. pointer of 'unsigned char' == 'char'!?

8. Please help with cdu33a!!!

9. 8-bit ISA > 16-bit MCA, what ADF's?

10. Cheapo PnP SB Pro clone: 8-bit works, 16-bit doesn't

11. A problem about 8-bit charactor display on DOS Emulation

12. 8-bit display on 24-bit system?

13. 8-bit display on a 24-bit adapter?