KDE2 prob: libkdecore.so.3 and symbols(?)

KDE2 prob: libkdecore.so.3 and symbols(?)

Post by Kyle Parfre » Mon, 12 Feb 2001 23:40:25



Hello all,
I have installed kde2.01 on a debian 2.2 system, which ran fine, but now
refuses to load. I get the following error message:
"/usr/lib/libkdecore.so.3 : undefined symbol :
getButtonShift_14QPlatinumStyle RiT1 "
from ksplash, kdeinit, knotify and a few others.
I had recently installed licq and the qt plugin, but it still doesn't
work upon removal of these. I also reinstalled kdelibs3 (the libary's
package) but it again didn't work.

Anyone know how to get kde to load again? How did this happen in the
first place?

Thanks,
Kyle

 
 
 

KDE2 prob: libkdecore.so.3 and symbols(?)

Post by Markus Kossman » Tue, 13 Feb 2001 01:35:35



> Hello all,
> I have installed kde2.01 on a debian 2.2 system, which ran fine, but now
> refuses to load. I get the following error message:
> "/usr/lib/libkdecore.so.3 : undefined symbol :
> getButtonShift_14QPlatinumStyle RiT1 "

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

That's a symbol from libqt. So check again what version of libqt is used
( "ldd /usr/lib/libkdecore.so.3" will list the used libqt )

--
Markus Kossmann                                    


 
 
 

KDE2 prob: libkdecore.so.3 and symbols(?)

Post by Kyle Parfre » Tue, 13 Feb 2001 02:43:12


The line from ldd is :
libqt.so.2 => /usr/lib/libqt.so.2 (0x40332000)

That file does exist in /usr/lib.
How can I correct the problem??
Kyle



>> Hello all,
>> I have installed kde2.01 on a debian 2.2 system, which ran fine, but now
>> refuses to load. I get the following error message:
>> "/usr/lib/libkdecore.so.3 : undefined symbol :
>> getButtonShift_14QPlatinumStyle RiT1 "

> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

> That's a symbol from libqt. So check again what version of libqt is used
> ( "ldd /usr/lib/libkdecore.so.3" will list the used libqt )

 
 
 

1. Can't start KDE2: /opt/kde2//lib/libkdecore.so.3: undefined symbol: __ti8QUriDrag

When i try to start KDE2 i get this error message:
--------------------------------------------------
moon:/ # ksplash: error while loading shared libraries:
/opt/kde2//lib/libkdecore.so.3: undefined symbol: __ti8QUriDrag
kdeinit: error while loading shared libraries:
/opt/kde2//lib/libkdecore.so.3: undefined symbol: __ti8QUriDrag
knotify: error while loading shared libraries:
/opt/kde2//lib/libDCOP.so.1: undefined symbol:
childEvent__7QObjectP11QChildEventksmserver: error while loading
shared libraries: /opt/kde2//lib/libkdecore.so.3: undefined symbol:
__ti8QUriDrag
connect() failed: : No such file or directory
--------------------------------------------------

I've reinstalled KDE2 twice and i still get the error.
Any idea of which library packet i will have to re-install?

Cheers!

2. Please Explain

3. libkdecore.so.1 undefined symbol

4. Integrated Unix and VMS data management

5. I broke libkdecore.so.3.0.0?

6. Mandrake and alpha

7. Problem with libkdecore.so.2

8. mount and Unmount CD

9. Why do I get this libkdecore.so.0: err?

10. shared libraries: libkdecore.so

11. libkdecore.so.3 error

12. Euro symbol in KDE2

13. Kde2 crashes on startup: undefined symbol: getButtonShift__14QPlatinumStyleRiT1