Help! PostgreSQL Won't Start

Help! PostgreSQL Won't Start

Post by Berni » Sun, 02 Aug 1998 04:00:00



whenever I attempt to start the postmaster, I get the
following error:

FindBackend: found "/usr/bin/postgres" using argv[0]
FATAL: StreamServerPort: bind() failed: errno=13
        Is another postmaster already running on that port?
        If not, remove socket node (/tmp/.s.PGSQL.<portnr>)and retry.

I'ts been working fine for several weeks until recently.  There are
no files in /tmp relating to postgreSQL.  The port I'm using is not in
use by another process, determined with the ps auxw|grep postma
command, and also, fuser -vun tcp 5432.

Here's the command I'm using to start postmaster:
nohup /usr/bin/postmaster -i -B 256 -p 5432 -d -D /var/lib/pgsql

Quote:>/home/postgres/pgsql.log 2>/home/postgres/pgsql.err &

I'm using postgreSQL 6.3.2 under RedHat Linux 5.1.
Any suggestions would be greatly appreciated.
 
 
 

Help! PostgreSQL Won't Start

Post by Jon Gunnar R » Tue, 04 Aug 1998 04:00:00



Quote:>remove the socket in /tmp, most likely named =.s.PGSQL.5432

>when an unclean shutdown occurs (power off) postgres cannot clean up.
> It is also a good idea to make an entry in your bootup scripts, somewhere
>before the network and postgres comes up, to remove the socket if there
>is one in /tmp.

Thanks a lot, this made my day to. The error messages I got were more
cryptic, but the reason were the same.

--

Jon Gunnar Rue
Running RedHat Linux

 
 
 

1. Help! PostgreSQL Won't Start

whenever I attempt to start the postmaster, I get the
following error:

FindBackend: found "/usr/bin/postgres" using argv[0]
FATAL: StreamServerPort: bind() failed: errno=13
        Is another postmaster already running on that port?
        If not, remove socket node (/tmp/.s.PGSQL.<portnr>)and retry.

I'ts been working fine for several weeks until recently.  There are
no files in /tmp relating to postgreSQL.  The port I'm using is not in
use by another process, determined with the ps auxw|grep postma
command, and also, fuser -vun tcp 5432.

Here's the command I'm using to start postmaster:
nohup /usr/bin/postmaster -i -B 256 -p 5432 -d -D /var/lib/pgsql

I'm using postgreSQL 6.3.2 under RedHat Linux 5.1.
Any suggestions would be greatly appreciated.

2. How to age messages files

3. X won't start: can't open default font 'fixed'

4. unable to compile Kexpress 0.1.7

5. VB 6.0 ADO won't talk to PostgreSQL driver

6. Endless Loop Script Died Suddenly

7. x-win won't start with eth0 enabled

8. A TRUE Value Add!

9. x-win won't start with eth0 enabled!

10. 'Server already active for display 0' - won't start

11. X won't start "could not find font 'fixed'"

12. grahical login program tanks, system won't start, help!

13. Xwindows won't start.....help needed