A couple simple questions

A couple simple questions

Post by Nathan Dwy » Fri, 30 Sep 1994 23:36:03



Hi.

I'm just getting into Linux, and liking it a whole lot. I just have a few
problems so far I was wondering if anyone could help me with.

I printed once.  No CR.  I tried changing some of the printcap around, no
luck.  I changed it back.  Now, when I lpd something, all I get are blank
pages.  I'm currently using the generic printer entry.  I have a Laserjet
4ML.

Secondly, I can't receive files over the modem with minicom.  The blue
receive box comes up, pauses for a bit, then dissapears.  If I use xmodem
and switch to a shell to run rz -vv I get the error that it can't open
/var/adm/szlog.  I made a dummy szlog, and even changed the group
ownership from root to users, but no luck.

Can anyone give me some pointers to help, or any suggestions?

Thanks in advance,
nathan

 
 
 

A couple simple questions

Post by Dennis Heltz » Mon, 03 Oct 1994 00:27:15


: I printed once.  No CR.  I tried changing some of the printcap around, no
: luck.  I changed it back.  Now, when I lpd something, all I get are blank
: pages.  I'm currently using the generic printer entry.  I have a Laserjet
: 4ML.

The no CR problem (sometimes called the stairstep effect) results from
the difference between DOS and UNIX text files. DOS terminates each line
with a CR/LF combination; UNIX only uses a LF. The Laserjet is expecting
a DOS type file and to prevent double spacing, does not perform a CR
unless explicitly told to. This means each line starts in the vertical
column right after where the last line stopped, creating a staricase
effect.

To fix it permanently, you need to use an input filter that adds the CR
to the printfile as it is processed. I'd suggest you look at the
Printing HOWTO, it explains this better and gives examples.

: Secondly, I can't receive files over the modem with minicom.  The blue
: receive box comes up, pauses for a bit, then dissapears.  If I use xmodem
: and switch to a shell to run rz -vv I get the error that it can't open
: /var/adm/szlog.  I made a dummy szlog, and even changed the group
: ownership from root to users, but no luck.

I'm confused about whether you want to use xmodem or zmodem. When I want
to download a file, I just type "sz filename" and minicom handles the
receiving automatically. Try that and follow up this post with more
specifics if it doesn't work.

Dennis