OpenOffice returns "Get_local_host: 'localhost' IP address not available!"

OpenOffice returns "Get_local_host: 'localhost' IP address not available!"

Post by Otis Hunt » Wed, 05 Jun 2002 07:19:50



I am running redhat 7.3.  When I start up OpenOffice, I get:

   Get_local_host: 'localhost' IP address not available!

This started to happen after I made my IP address static and I changed
my hostname.  The following steps are what I performed:

1) Edit /etc/sysconfig/network-scripts/ifcfg-eth0:

   Change: BOOTPROTO='static'
   Added:  IPADDR=192.168.2.99
           NETMASK=255.255.255.0

2) Edit /etc/sysconfig/network
   Change: HOSTNAME='microsoftsucks'
   Added:  GATEWAY=192.168.2.1

3) Edit /etc/hosts
   192.168.2.99 microsoftsucks

4) /etc/init.d/network restart

When I do a '/sbin/ifconfig' I show that my IP address is
'192.168.2.99' and hostname returns 'microsoftsucks'.  I deinstalled
and then reinstalled OpenOffice and I even rebooted after I made the
above changes but I still get the same error.  I have not noticed any
other problems with any other application so I am a bit confussed why
only OpenOffice is having this problem.  Is this a Linux
administration problem due to me not doing all that I should have to
change my IP address or is it a problem with OpenOffice?

Thanks!

Otis

 
 
 

OpenOffice returns "Get_local_host: 'localhost' IP address not available!"

Post by Bill Unr » Wed, 05 Jun 2002 08:19:46


]I am running redhat 7.3.  When I start up OpenOffice, I get:

]   Get_local_host: 'localhost' IP address not available!

]This started to happen after I made my IP address static and I changed
]my hostname.  The following steps are what I performed:

]1) Edit /etc/sysconfig/network-scripts/ifcfg-eth0:

]   Change: BOOTPROTO='static'
]   Added:  IPADDR=192.168.2.99
]           NETMASK=255.255.255.0

]2) Edit /etc/sysconfig/network
]   Change: HOSTNAME='microsoftsucks'
]   Added:  GATEWAY=192.168.2.1

]3) Edit /etc/hosts
]   192.168.2.99 microsoftsucks

]4) /etc/init.d/network restart

]When I do a '/sbin/ifconfig' I show that my IP address is
]'192.168.2.99' and hostname returns 'microsoftsucks'.  I deinstalled
]and then reinstalled OpenOffice and I even rebooted after I made the
]above changes but I still get the same error.  I have not noticed any
]other problems with any other application so I am a bit confussed why
]only OpenOffice is having this problem.  Is this a Linux
]administration problem due to me not doing all that I should have to
]change my IP address or is it a problem with OpenOffice?

localhost is a specific ip, and you should have an entry in /etc/hosts
which says
127.0.0.1 localhost

 
 
 

OpenOffice returns "Get_local_host: 'localhost' IP address not available!"

Post by David K. Mean » Wed, 05 Jun 2002 10:06:18



> I am running redhat 7.3.  When I start up OpenOffice, I get:

>    Get_local_host: 'localhost' IP address not available!

> This started to happen after I made my IP address static and I changed
> my hostname.

 As a previous poster said, you need to have `localhost' declared in
your /etc/hosts file.  What was not so clear is that you can have
several names for the same machine.  So in your case, you might want

127.0.0.1       microsoftsucks  localhost.localdomain   localhost

as your (first) line in this file.  The first name on the line
is the one that becomes your "hostname", but the others are
available for requestors wanting to find the address corresponding
to a name they know.

HTH

 
 
 

OpenOffice returns "Get_local_host: 'localhost' IP address not available!"

Post by Ken Bloo » Wed, 05 Jun 2002 11:45:03




> ]I am running redhat 7.3.  When I start up OpenOffice, I get:

> ]   Get_local_host: 'localhost' IP address not available!

> ]This started to happen after I made my IP address static and I changed
> ]my hostname.  The following steps are what I performed:

> ]1) Edit /etc/sysconfig/network-scripts/ifcfg-eth0:

> ]   Change: BOOTPROTO='static'
> ]   Added:  IPADDR=192.168.2.99
> ]           NETMASK=255.255.255.0

> ]2) Edit /etc/sysconfig/network
> ]   Change: HOSTNAME='microsoftsucks'
> ]   Added:  GATEWAY=192.168.2.1

> ]3) Edit /etc/hosts
> ]   192.168.2.99 microsoftsucks

> ]4) /etc/init.d/network restart

> ]When I do a '/sbin/ifconfig' I show that my IP address is
> ]'192.168.2.99' and hostname returns 'microsoftsucks'.  I deinstalled
> ]and then reinstalled OpenOffice and I even rebooted after I made the
> ]above changes but I still get the same error.  I have not noticed any
> ]other problems with any other application so I am a bit confussed why
> ]only OpenOffice is having this problem.  Is this a Linux
> ]administration problem due to me not doing all that I should have to
> ]change my IP address or is it a problem with OpenOffice?

> localhost is a specific ip, and you should have an entry in /etc/hosts
> which says
> 127.0.0.1 localhost

And you should ensure that /sbin/ifconfig also tells you about a network interface named "lo"
assigned to IP address 127.0.0.1
 
 
 

1. LPD: Latitude Get_local_host: 'localhost' IP address not available!

I'm running redhat linux 7.1. I changed my host name from
localhost.localdomain to Latitude. On boot lpd starts and says:
2001-09-23-10:10:40.546 Latitude Get_local_host: 'localhost' IP
address not available!
When I try to print something nothing happens. I don't even get an
error message. Does anybody know how I can solve this problem? Any
help would be greatly appreciatet.

greetz,

Niels

2. Remote installation of AIX?

3. Cygwin bash "id -un" returns "Administrator" when I'm not

4. System V shared memory consistency on multiprocessor machines

5. Apache on Linux: "localhost" serves up OK, but not the IP address/index.html

6. Win95/Linux/Win NT 4.0 server

7. Does select return "read ready" or "won't block" status?

8. XFree86 3.1 & gpm: mouse problems on ATI GU+

9. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

10. Why doesn't echo "text" 'command' "more text" work?

11. Can ping "localhost" but can't ping my own IP...why?

12. "127.1" works, but "localhost" does not!