User mounting a floppy -- fstab 'user' fails ???

User mounting a floppy -- fstab 'user' fails ???

Post by Frank Mil » Wed, 19 Mar 1997 04:00:00



Users cannot mount /dev/fd0, even with the fstab line:

/dev/fd0     /mnt/floppy auto rw,user,noauto,suid,dev,async,exec 0 0

Why is this??? [works fine as root]

[Debian 1.2.4, kernel patched to 2.0.28]

TIA...

        -frank

 
 
 

User mounting a floppy -- fstab 'user' fails ???

Post by Eberhard Bur » Wed, 19 Mar 1997 04:00:00



> Users cannot mount /dev/fd0, even with the fstab line:

> /dev/fd0     /mnt/floppy auto rw,user,noauto,suid,dev,async,exec 0 0

> Why is this??? [works fine as root]

> [Debian 1.2.4, kernel patched to 2.0.28]

Debian seems to set the permissions on /dev/* in a rather paranoid
fashion.
#> chmod ugo+rw /dev/fd0
should do.

Mahlzeit,
--


 
 
 

User mounting a floppy -- fstab 'user' fails ???

Post by David Sye » Thu, 20 Mar 1997 04:00:00



> Users cannot mount /dev/fd0, even with the fstab line:

> /dev/fd0     /mnt/floppy auto rw,user,noauto,suid,dev,async,exec 0 0

check permissions of /dev/fd0

Dave.

 
 
 

User mounting a floppy -- fstab 'user' fails ???

Post by Dan » Thu, 20 Mar 1997 04:00:00



> Users cannot mount /dev/fd0, even with the fstab line:

> /dev/fd0     /mnt/floppy auto rw,user,noauto,suid,dev,async,exec 0 0

> Why is this??? [works fine as root]

> [Debian 1.2.4, kernel patched to 2.0.28]

> TIA...

>         -frank

Check the permissions on /bin/mount, and make sure that they are 4755
(-rwsr-xr-x).  The perms on /bin/umount should be the same.  If your
system is used by more than 1 user, and you are concerned about
security,
get the newest version of mount.  Older versions have a * overflow
problem.
 
 
 

User mounting a floppy -- fstab 'user' fails ???

Post by Geoff Sho » Fri, 21 Mar 1997 04:00:00


: >
: > Users cannot mount /dev/fd0, even with the fstab line:
: >
: > /dev/fd0     /mnt/floppy auto rw,user,noauto,suid,dev,async,exec 0 0
: >
:
: check permissions of /dev/fd0

Also, try it with filetype msdos instead of auto.

        Geoff
--
----------------------------------------------------------------------------
Ever sit and watch ants? They're always busy with                Geoff Short

can't identify with that kind of work ethic. http://kipper.york.ac.uk/~geoff

 
 
 

1. Smartmedia can't mount as user, can't write to as user

I've been trying to get users to access my SmartMedia card reader in
RH 8.0 and I can mount it in root and write to it in root but with
users, no luck. Here's my fstab file:

dev/sda1  /mnt/smartmedia  vfat  noauto,user,rw 0 0

What can I do so users can mount the reader themselves and also write
to it as well?

Thanks for the help.

2. Wanted: Server Colocation Space

3. user/users mount/umount confusion with fstab

4. How to convert sgml man pages to HTML?

5. Normal user can't mount floppy on RedHat 6.0..why????

6. 2.4.4-pre1 Unresolved symbols "strstr"

7. how to allowing users to mount cd's, floppies, or ntfs?

8. Install Prob using Adaptec Total CD Kit (AVA 1505)

9. User can't mount CDROM & Floppy

10. mount floppy for user's access

11. Users can't mount (CD-ROM, floppy) drives?

12. User can't mount CDROM & Floppy

13. can't mount cd-rom/floppy as normal user