Xlib: extension "RENDER" missing on display ":0.0".

Xlib: extension "RENDER" missing on display ":0.0".

Post by Art » Wed, 29 Aug 2001 10:15:36



When I try to run kmix I get a message:

"Xlib:  extension "RENDER" missing on display ":0.0"."

System is RH7.1 with kernel 2.4.5.

Any ideas?

Art

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Vladimir Florinsk » Wed, 29 Aug 2001 13:48:59



> When I try to run kmix I get a message:

> "Xlib:  extension "RENDER" missing on display ":0.0"."

> System is RH7.1 with kernel 2.4.5.

We need to know your video card model. Some applications need antialiased
fonts and this feature is not present in your server.
--

Vladimir

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Stephen Anthon » Wed, 29 Aug 2001 21:18:37



> When I try to run kmix I get a message:

> "Xlib:  extension "RENDER" missing on display ":0.0"."

> System is RH7.1 with kernel 2.4.5.

> Any ideas?

> Art

It means that the Render extension isn't part of your XFree86 video card
drivers.  Unless it causes a program to not run, then don't worry about
it, its just a debug message.

Steve

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Art » Thu, 30 Aug 2001 09:08:07



> We need to know your video card model. Some applications need antialiased
> fonts and this feature is not present in your server.
> --

Vladimir,

Thanks for your reply.

Video card is generic with SiS6326 chip, 8 Meg of memory, tho
X -probeonly tells me it is only using 4 Meg.

BTW, in Control Center -> Look & Feel -> Style, anti-aliasing
is disabled.

Art

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Art » Thu, 30 Aug 2001 09:14:50



> It means that the Render extension isn't part of your XFree86 video card
> drivers.  Unless it causes a program to not run, then don't worry about
> it, its just a debug message.

 Thanks for your reply.

It is causing a program not to run, namely kmix.

Art

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Robert_ » Thu, 30 Aug 2001 09:57:58




>> It means that the Render extension isn't part of your XFree86 video card
>> drivers.  Unless it causes a program to not run, then don't worry about
>> it, its just a debug message.

>  Thanks for your reply.

> It is causing a program not to run, namely kmix.

> Art

What makes you believe that a extension that helps render anti-aliased
fonts is causing your sound mixer not to work?
I'm not saying I have knowledge in this area or that it is not a
possibility,  but I'm just wondering what you are basing this seemingly
implausible conclusion on?
Robert_L
--
Registered linux user #214645
 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Art » Thu, 30 Aug 2001 13:38:55



> What makes you believe that a extension that helps render anti-aliased
> fonts is causing your sound mixer not to work?
> I'm not saying I have knowledge in this area or that it is not a
> possibility,  but I'm just wondering what you are basing this seemingly
> implausible conclusion on?

Robert,

From: <http://sdb.suse.de/de/sdb/html/extrender.html>

Art

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Robert_ » Thu, 30 Aug 2001 14:35:55




>> What makes you believe that a extension that helps render anti-aliased
>> fonts is causing your sound mixer not to work?
>> I'm not saying I have knowledge in this area or that it is not a
>> possibility,  but I'm just wondering what you are basing this seemingly
>> implausible conclusion on?

> Robert,

> From: <http://sdb.suse.de/de/sdb/html/extrender.html>

> Art

Art,
I don't see anything in this article that is differnet from what we have
been saying to you and that I was already well aware of.  
My question to you was why do you think :
<quote>
It is causing a program not to run, namely kmix.
<end quote>
Robert_L
--
Registered linux user #214645
 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Vladimir Florinsk » Fri, 31 Aug 2001 04:41:14


 > Video card is generic with SiS6326 chip, 8 Meg of memory, tho X
 > -probeonly tells me it is only using 4 Meg.
 >
 > BTW, in Control Center -> Look & Feel -> Style, anti-aliasing is
 > disabled.
 >

Ok, I am not very familiar with KDE. I heard it was the first to offer
AA font support in the QT widget set. Render is supported by XFree on
all "better" cards (3dxf, ATI, Matrox, NVidia). Since you don't have one
of these, you are somewhat out of luck.

The real issue is whether it's a real problem for you. I understand that
other KDE apps are running fine. If it's just the mixer that's refusing
to run, you should contact the author and point this out.

Vladimir

 
 
 

Xlib: extension "RENDER" missing on display ":0.0".

Post by Art » Fri, 31 Aug 2001 06:01:24



> The real issue is whether it's a real problem for you. I understand that
> other KDE apps are running fine. If it's just the mixer that's refusing
> to run, you should contact the author and point this out.

Vladimir,

No, it's not a real problem, I have other mixers available: alsamixer,
aumix.  I would prefer to use kmix as the GUI interface is better.

I like your idea, contact the author.

Art