softraid problem with SuSE 6.4 and 2.2.x kernel

softraid problem with SuSE 6.4 and 2.2.x kernel

Post by Clemens Ende » Wed, 12 Jul 2000 04:00:00



hi,

I'm using SuSE 6.4 Distribution and the 2.2.16-kernel. When I compiled the
kernel I enabled RAID-option and built raid-support as modules.
I also have raidtools 0.9 installed.
I did NOT patch the kernel or something.

/etc/raidtab looks like this:

raiddev /dev/md0
          raid-level      0
          nr-raid-disks   2
          persistent-superblock 1
          chunk-size     4
          device          /dev/sdd1
          raid-disk       0
          device          /dev/sde1
          raid-disk       1

then I call "mkraid /dev/md0"

handling MD device /dev/md0
analyzing super-block
disk 0: /dev/sdd1, 8956206kB, raid superblock at 8956096kB
disk 1: /dev/sde1, 8956206kB, raid superblock at 8956096kB
mkraid: aborted, see the syslog and /proc/mdstat for potential clues.

cat /proc/mdstat
Personalities : [2 raid0]
read_ahead not set
md0 : inactive
md1 : inactive
md2 : inactive
md3 : inactive

In the syslog files I dont find any error-message.

What's the problem here ?

Thnx for your help in advance,

Clemens

PS: leute die deutsch sprechen sollen ruhig auf deutsch antworten.

 
 
 

softraid problem with SuSE 6.4 and 2.2.x kernel

Post by Johannes Nies » Wed, 12 Jul 2000 04:00:00



> hi,

> I'm using SuSE 6.4 Distribution and the 2.2.16-kernel. When I compiled the
> kernel I enabled RAID-option and built raid-support as modules.
> I also have raidtools 0.9 installed.
> I did NOT patch the kernel or something.

Clemens,

you are using the kernel portion of raid version 0.4 with raidtools
0.9. It does not fit. I'd suggest patching your kernel to raid
0.9. You can find the patches somewhere on the redhat server.

Johannes Nie?

 
 
 

softraid problem with SuSE 6.4 and 2.2.x kernel

Post by Ralf Prenge » Thu, 13 Jul 2000 04:00:00




Quote:

> you are using the kernel portion of raid version 0.4 with raidtools
> 0.9. It does not fit. I'd suggest patching your kernel to raid
> 0.9. You can find the patches somewhere on the redhat server.

you can find them here
http://people.redhat.com/mingo/raid-patches/

--

Ralf Prengel Faxscape Deutschland

 
 
 

softraid problem with SuSE 6.4 and 2.2.x kernel

Post by Clemens Ende » Thu, 13 Jul 2000 04:00:00


Quote:

> > you are using the kernel portion of raid version 0.4 with raidtools
> > 0.9. It does not fit. I'd suggest patching your kernel to raid
> > 0.9. You can find the patches somewhere on the redhat server.

> you can find them here
> http://people.redhat.com/mingo/raid-patches/

thnx a lot !
 
 
 

softraid problem with SuSE 6.4 and 2.2.x kernel

Post by blowfis » Tue, 18 Jul 2000 04:00:00



> > > you are using the kernel portion of raid version 0.4 with raidtools
> > > 0.9. It does not fit. I'd suggest patching your kernel to raid
> > > 0.9. You can find the patches somewhere on the redhat server.

> > you can find them here
> > http://people.redhat.com/mingo/raid-patches/

> thnx a lot !

Be careful.  Most Red Hat's RPM won't work with SuSE.

Might even break something else for you.

-blowfish.