LP Admin Question

LP Admin Question

Post by Da.. » Fri, 04 Aug 2000 04:00:00



I am new to Linux and need to find the name of the printer on our SuSe 6.1
machine. I am adding the printer (as remote) to an HP-UX box.

There are 3 files in /dev: lp0, lp1 & lp2. There is a /var/spool/lp1
directory, but using "lp1" from the remote host does not work. Neither does
"/dev/lp1". A test print from the remote host appears to be sent, but never
gets to the printer.

What is the Linux equivalent utility to lpstat or lpadmin?

Thanks in advance.

David.

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

LP Admin Question

Post by Marc D Bumbl » Mon, 07 Aug 2000 04:00:00


have you tried running printtool as root?

marc

    David> I am new to Linux and need to find the name of the printer
    David> on our SuSe 6.1 machine. I am adding the printer (as
    David> remote) to an HP-UX box.

    David> There are 3 files in /dev: lp0, lp1 & lp2. There is a
    David> /var/spool/lp1 directory, but using "lp1" from the remote
    David> host does not work. Neither does "/dev/lp1". A test print
    David> from the remote host appears to be sent, but never gets to
    David> the printer.

    David> What is the Linux equivalent utility to lpstat or lpadmin?

    David> Thanks in advance.

    David> David.

    David> Sent via Deja.com http://www.deja.com/ Before you buy.

--

 
 
 

1. admin user can't admin non-admin groups

In the attributes for user profile "jean" I've specified "adminstrative
user=true" and "administrative group=staff".

In the "staff" group profile attributes I've specified "administrative
group=false" and "administrator list=jean".

The above were done as by "root".

When I then sign in as "jean" and look at the "staff" group attributes
(via SMIT) it shows "adminstrative group=true" and the "administrator
list=" parameter is blank.  If I try to make an addition, say, to
the "user list=" parameter and hit OK, SMIT dies and the change doesn't
get made.  Further, if I go into Application Manager as "jean" and try
to edit "staff" group I am told "you do not have access to edit this
dialoge."

Have I got a bug or am I doing something wrong in the way I set
up "jean" and "staff"?

Thanks.

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

2. STREAMS modules what's the point?

3. lp(1) suid to lp-Secure files fail.

4. Converting htaccess files to nsconfig

5. #$%@! lp:Solaris remote lp failing

6. 2.4.19-pre9: fs/locks.c

7. lp: unable to get major 6 - Initialization of lp failed

8. Masquerading over Serial PPP link

9. lp-init: no lp devices found

10. Modifying lp & lp sched

11. HPLJ4l lp init: no lp devices found

12. Starting lpd: Warning - lp: cannot stat lp device '/dev/lp0'

13. LP doesn't work after lp jumbo patch