Xconfig problems

Xconfig problems

Post by Your Name He » Mon, 04 Apr 1994 06:48:59



I am trying to configure my system using one of the example files (.22) that
came with the distribution from ftp.cdrom.  It has the following keyboard
section:

Keyboard
  AutoRepeat 500 5
  ServerNumlock
  Xleds      1 2 3

BUT, when I attempt to start X, it gets a fatal server error and says that the
Xconfig must have a define a keyboard.  Am I missing something?

Bill

 
 
 

Xconfig problems

Post by Pierre Uszyns » Fri, 08 Apr 1994 03:16:54



Quote:>BUT, when I attempt to start X, it gets a fatal server error and says that the
>Xconfig must have a define a keyboard.  Am I missing something?

Are you looking at the right Xconfig file? The man page for X386
mentions several paths the server checks:

$HOME/Xconfig
/etc/Xconfig
/usr/X386/lib/X11/Xconfig.(hostname)
/usr/X386/lib/X11/Xconfig

You may not be looking at the first one it finds.
Pierre Uszynski,


 
 
 

1. OPTi931 - make xconfig problem !?

I was following the steps outlined in the OPTi931 Mini-HOWTO
(http://spoke.nols.com/~drees/opti931.html), and was in
"Configuring/Compiling the Kernel", using make xconfig. Basically, I
indicated that sound card support be compiled as a module, and selected
'M' (instead of 'Y' as indicated in the mini-HOWTO because sound is
compiled as a module, therefore 'Y' is disabled) for the following:

M    Generic OPL2/OPL3
M    MPU-401 support (NOT for SB16)
M    Microsoft Sound System support
M    FM synthesizer (YM3812/OPL-3) support

Now I was trying to change the IRQ, I/O, DMA, etc... settings under
"MPU-401 support" and "Microsoft Sound System support", but make xconfig
doesn't allow me to.

Am I missing something? Or are these really disabled?

Thanks,

John

2. *Commercial* support for Diamond or Matrox??

3. Xconfig problems

4. X 3.3.2

5. Xconfig problem

6. quota

7. sound module xconfig problem with kernel 2.0.33

8. How does SunOS to implement FIFO?

9. Xconfig problem, Please help!

10. Xconfig problem

11. Xconfig problems with ATI Ultra+

12. Xconfig problems - STB Powergraph/NEC Multisync III

13. Xconfig problem on higher resolution than 640x480