meta key doesn't work in xterms with Redhat-6.0

meta key doesn't work in xterms with Redhat-6.0

Post by Michael Keightle » Fri, 07 May 1999 04:00:00



Just installed Redhat-6.0.  The Meta key no longer works in bash in xterms
(i.e. the Alt Key of PC keyboards).  It works ok in Redhat-5.2.  The
xterms seem to be producing 8-bit characters now,  which I definitely
don't want. Any idea how to fix it?  (Using the Escape key isn't the answer!)

Michael
--
_________

Systems Manager                              Fax: +44 131 220 4492
Quadstone Limited                            WWW: http://www.quadstone.com

 
 
 

meta key doesn't work in xterms with Redhat-6.0

Post by T.E.Dicke » Sat, 08 May 1999 04:00:00



> Just installed Redhat-6.0.  The Meta key no longer works in bash in xterms
> (i.e. the Alt Key of PC keyboards).  It works ok in Redhat-5.2.  The
> xterms seem to be producing 8-bit characters now,  which I definitely
> don't want. Any idea how to fix it?  (Using the Escape key isn't the answer!)

probably someone changed a resource setting, or else they've dropped
nxterm (a good idea) - in the manpage:

     eightBitInput (class EightBitInput)
             If true, Meta characters input from the keyboard are
             presented  as a single character with the eighth bit
             turned on.  If false, Meta characters are  converted
             into  a  two-character  sequence  with the character
             itself preceded by ESC.  The default is ``true.''  

--
Thomas E.*ey

http://www.veryComputer.com/

 
 
 

1. META key doesn't work in xterm?

Hello,

I have a problem with xterm: META key doesn't work.
And also the emacs style command line editing like `M-b'.
It all works fine on the virtual consoles and in a rxvt,
but doesn't in xterm.

My META key is ALT:
  Xconfig:
  LeftAlt         Meta
  RightAlt        ModeShift
  ScrollLock      Compose

Using ESC instead of ALT works also in xterm without changing the
META key entry in Xconfig, i.e. ESC works as META key without saying
it is a META key!?

I use bash, but I've tested too with tcsh.
I've tested different combinations of `meta-flag' and `convert-meta'
in `.inputrc', but I think it isn't a problem of the shell but a
problem of xterm.

Have anybody solved the problem?

Regards

Uwe

--

Lake of Konstanz                Germany

2. Western Digital EIDE disks

3. meta key in tcsh doesn't work

4. Data acquisition with Linux?

5. ALT (or META) key doesn't work in syscons.

6. How can I integrate FAX with email on Unix?

7. meta/alt key doesn't work from remotely launched emacs

8. CLASSPATH Question

9. command(meta) key doesn't work in X

10. Meta key doesn't work from remotely launched emacs

11. Bar key doesn't work in XTERM, help please.

12. Compose key doesn't work in xterm

13. IP Accounting doesn't work for PPP dial-ins :-(( ??