Old ReiserFS Won't Mount After Re-Installation

Old ReiserFS Won't Mount After Re-Installation

Post by Markus Ker » Wed, 14 May 2003 01:25:36



 Hi there!

 I've a big problem - in fact, two: 1, I'm afraid I've lost a complete
partition incl. some very urgent data, 2. I'm about to panic!!!

 Well, I hope you can help me with the first ...

- Have (had ?) a seperate hdb with ONE reiserFS partition: hdb1

- Have deleted any partitions on hda, disconnected hdb, and have
installed Suse 8.0

- Thought I could reconnect and mount hdb1 after having finished
installation by adding /dev/hdb1 reiserfs blabla... to fstab

- Linux hangs while booting when trying to "check partition" ...

- Please tell me there *is* a chance to read that partition, please -
I'm in trouble, if that won't work ...

Sincerely,

M.K.

 
 
 

Old ReiserFS Won't Mount After Re-Installation

Post by Jeroen Geilma » Thu, 15 May 2003 02:15:26



>  Hi there!

>  I've a big problem - in fact, two: 1, I'm afraid I've lost a complete
> partition incl. some very urgent data, 2. I'm about to panic!!!

>  Well, I hope you can help me with the first ...

> - Have (had ?) a seperate hdb with ONE reiserFS partition: hdb1

> - Have deleted any partitions on hda, disconnected hdb, and have
> installed Suse 8.0

> - Thought I could reconnect and mount hdb1 after having finished
> installation by adding /dev/hdb1 reiserfs blabla... to fstab

WHAT blabla?
NO blabla - be EXACT here, you CANNOT mount a reiserfs like an ext2!

#man mount

 > - Linux hangs while booting when trying to "check partition" ...

Hangs.. or takes a long time ? BE SURE

Does the new kernel even HAVE reiserfs support ?
THAT would be the kind of mistake you can lose sleep over ;-)

BTW: Reiserfs has not been stable for very long, so make SURE the kernel
has an adequately MODERN verison of the reiserfs module *AND UTILS* -
this is verra verra important ! The utils check the FS on boot...

Why not get a real Linux (like Knoppix) and just CHECK the FS without
needing a complete installation anywhere ?

J

 
 
 

1. Old Reisner Won't Mount After Re-Installation

 Hi there!

 I've a big problem - in fact, two: 1, I'm afraid I've lost a complete
partition incl. some very urgent data, 2. I'm about to panic!!!

 Well, I hope you can help me with the first ...

- Have (had ?) a seperate hdb with ONE reiserFS partition: hdb1

- Have deleted any partitions on hda, disconnected hdb, and have
installed Suse 8.0

- Thought I could reconnect and mount hdb1 after having finished
installation by adding /dev/hdb1 reiserfs blabla... to fstab

- Linux hangs while booting when trying to "check partition" ...

- Please tell me there *is* a chance to read that partition, please -
I'm in trouble, if that won't work ...

Sincerely,

M.K.

2. deskjet 670c - any probs with linux

3. help?: Re-installation of Vision 97 (processes won't start)

4. Linux META-FAQ

5. Change user name with admintool, old mount won't go away.

6. NFS mount problems

7. Apache Server's re-installation

8. Connection problems..

9. NFS mount won't mount at boot, but mount -a works fine.

10. ReiserFS mount option 'notail'

11. Starbuck won't boot, rescue disk won't mount

12. YDL 2.3 Installation Problem: won't mount CD

13. Installation won't mount CD NEC 3xi on SoundBlaster SCSI-2