XEmacs 20.3-3 and RH 5.1

XEmacs 20.3-3 and RH 5.1

Post by Morten Ranhe » Sun, 12 Jul 1998 04:00:00



I was thinking about to start using xemacs. Also I am RH 5.1 user with
all stuffs updated to recent date.

When I try to install the xemacs 20.3-3 rpm package I get an error
"libpng.so.0" dependecies missing. I've also been looking around on
the xemacs ftp site where I found a 20.4 version. Is this the right
xemacs for rh 5.1?

So what do I need or what should I do?

--
Morten Ranheim

 
 
 

XEmacs 20.3-3 and RH 5.1

Post by Core » Sun, 12 Jul 1998 04:00:00



Quote:> I was thinking about to start using xemacs. Also I am RH 5.1 user with
> all stuffs updated to recent date.

> When I try to install the xemacs 20.3-3 rpm package I get an error
> "libpng.so.0" dependecies missing. I've also been looking around on
> the xemacs ftp site where I found a 20.4 version. Is this the right
> xemacs for rh 5.1?

> So what do I need or what should I do?

First off, are you sure you grabbed the xemacs rpm for the 'hurricane'
release? This is the name for 5.1.

Do a 'site exec locate xemacs-20.4' while on redhat's ftp server,
this will display a list of what your looking for.
Make sure you get one of the rpm's that are under the hurricane
dir.

In this specific case the package your looking for is in
/ftp/pub/contrib/hurricane/i386/xemacs-20.4-1.i386.rpm

If you still get libpng errors, post back , and we'll see what
we can come up with.

Beers!

Corey


 
 
 

XEmacs 20.3-3 and RH 5.1

Post by Morten Ranhe » Mon, 13 Jul 1998 04:00:00


In article <Pine.LNX.3.95.980711122253.26641C-100000



>/ftp/pub/contrib/hurricane/i386/xemacs-20.4-1.i386.rpm

>If you still get libpng errors, post back , and we'll see what
>we can come up with.

Well, I still get libpng errors from the xemacs-20.4-1. So what should I do
now?

Morten Ranheim

 
 
 

XEmacs 20.3-3 and RH 5.1

Post by Donovan Rebbech » Mon, 13 Jul 1998 04:00:00



> the xemacs ftp site where I found a 20.4 version. Is this the right
> xemacs for rh 5.1?

I think either should work

Quote:> So what do I need or what should I do?

do you have the libpng RPM installed ?  If not, install it. If you have
it, run ldconfig and try installing xemacs again

cheers,
--

http://pegasus.rutgers.edu/~elflord/
Web designer for Independence -- Linux for the Masses
http://independence.dunadan.com/

 
 
 

XEmacs 20.3-3 and RH 5.1

Post by Morten Ranhe » Tue, 14 Jul 1998 04:00:00




>> the xemacs ftp site where I found a 20.4 version. Is this the right
>> xemacs for rh 5.1?

>I think either should work

>> So what do I need or what should I do?

>do you have the libpng RPM installed ?  If not, install it. If you have
>it, run ldconfig and try installing xemacs again

If libpng wasn't installed, much of the X apps wouldn't run. An
updated RH 5.1 consist of the 1.0.1-3 version, while xemacs probably
only want's 0.99-XX versions. If I install any earlier versions of
libpng, I will probably get into some troubles which I don't wan't to
be in. :)

So what should I do next in order to get XEmacs installed?

--
Morten Ranheim

 
 
 

XEmacs 20.3-3 and RH 5.1

Post by Donovan Rebbech » Wed, 15 Jul 1998 04:00:00



> If libpng wasn't installed, much of the X apps wouldn't run. An

most Xapps don't need libpng. Mostly just graphics programs.

Quote:> updated RH 5.1 consist of the 1.0.1-3 version, while xemacs probably
> only want's 0.99-XX versions. If I install any earlier versions of
> libpng, I will probably get into some troubles which I don't wan't to
> be in. :)

> So what should I do next in order to get XEmacs installed?

I would try just installing both versions of libpng concurrently and see
how it goes. It shouldn't break your existing apps if you don't change
the libpng.so simlink ( you want libpng.so to point towards the libpng
you already have.)

cheers,
--

http://pegasus.rutgers.edu/~elflord/
Web designer for Independence -- Linux for the Masses
http://independence.dunadan.com/

 
 
 

1. Linux Quake 2 RH 5.1 with Kernel update 2.0.36-3

Got my PPP working with Netscape
Got my Quake installed
Got my mouse working after killing gpm
Got my sound working after updating to 2.0.36-3
problem:
When I try to connect to a server I get this:
Received signal 11, exiting

The list of servers shows up fine, but when I try to connect it does
this.

Something I noticed different than win98 is netstat returns TCP in win95
and linux shows UDP.

Second problem:
Been playing the game everythings peachy saving and loading files been
ok
then quake died with an error.  No problem I started up again tried to
load any of the save games, now when I try to load them:
recursive shutdown
Error. FS_read: 0 bytes.

Any help would be appreciated.

Thanks

VMaxx

2. curses problem

3. Xemacs 20.3/GNUS 5.5 on MkLinux?

4. Linux Shirt Sample...(sample.gif)

5. XEmacs 20.3 binary kits for Solaris-x86 available

6. Q: Program to force strict source routing

7. XEmacs 20.3 Info files Missing

8. Will you be able to send your kid to college?

9. building xemacs 20.3 for linuxppc

10. building xemacs 20.3 (still)

11. xemacs 20.3

12. Problem Updating RH5.0 to kernel-2.0.32-3 w/pcmcia-cs-2.9.12-3

13. 2.4.18-3 on rh 7.1?