Printing problem

Printing problem

Post by Hans Dumbraj » Fri, 28 Nov 1997 04:00:00



This is a multi-part message in MIME format.
--------------D9B67A984227059C0F014E20
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

--------------D9B67A984227059C0F014E20
Content-Type: message/rfc822
Content-Transfer-Encoding: 7bit
Content-Disposition: inline


Date: Thu, 27 Nov 1997 22:03:25 +0200

X-Mailer: Mozilla 4.04 [en] (X11; I; Linux 2.0.32 i586)
MIME-Version: 1.0
Newsgroups: comp.os.linux.setup
Subject: Printing problem
Content-Type: multipart/mixed; boundary="------------E1E1479B0B0876B338E5FE82"

This is a multi-part message in MIME format.
--------------E1E1479B0B0876B338E5FE82
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

--------------E1E1479B0B0876B338E5FE82
Content-Type: message/rfc822
Content-Transfer-Encoding: 7bit
Content-Disposition: inline


Date: Thu, 27 Nov 1997 21:56:42 +0200

X-Mailer: Mozilla 4.04 [en] (X11; I; Linux 2.0.32 i586)
MIME-Version: 1.0
Newsgroups: comp.os.linux.help,comp.os.linux.answers,comp.os.linux.setup
Subject: Printing problem
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

I have a problem with printing:
When doing "lpr filename" I get the following error message:



attempt"

Does anyone know a solution for this?
Thanx!


--------------E1E1479B0B0876B338E5FE82--

--------------D9B67A984227059C0F014E20--

 
 
 

1. Solaris 2.7 Print then No Print Problem

Server Configuration: Sun UltraSPARC-10, 300MHz UltraSPARC processor, with
256MB of RAM running Sun Solaris 2.7

I've been struggling with a, for me, perplexing problem in getting a cgi to
compile and work.  Note that this
software has been working under SUN 2.5 and 2.6.

The program uses a number of i/o functions, including lseek, open, close,
read, printf, fprintf, fwrite, and fgetc, as well as mSQL database
functions.  The problem is that the printf works initially, but then later
stops working; albeit without error.

I've stepped through the code with gdb and see nothing unusual.

Although I wouldn't doubt that there could well be a program problem on my
part, I don't see it.

The program flow is as follows.  Please note that while the program is
substantial in size, the process flow is exactly as shown; hence 99% of the
program doesn't execute prior to the difficulty.  The difficulty remains
consistent whether run from the prompt or as a database maintenance utility
in which HTML is parsed and written back to the server.

#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
. . .

int main()
{
    initialization();
    .  .  .

void initialization()
{
    llist entries;
    printf("before");
    cgiHTMLStatus = read_cgi_input(&entries);
    formActionString = cgi_val(entries, "formAction");
    printf("after");

    . . .

The second print statement doesn't appear!  the read_input_entries(...) is
http://www.eekim.com's cgihtml which is heavily used.  However, thinking
that it might be somehow connected with his code, I replaced
it with a version of my own and got exactly the same result - no printf
"after" output to stdout.

All software and libraries have been compiled on the same 2.7 system.

I have a hunch that somehow I have some incompatible headers or libraries in
the mix, but my checking has thusfar ruled that out.

I've tried lots of combinations in an effort to isolate the point where it
fails, but every combination has worked except for the combination I need to
produce the required functionality.  For instance, I have tried making a
program which contains all the same headers, but only the logic which is
exercised prior to the problem.  It worked!

I have several more things to try, but thought while I was trying them, I'd
check to see whether anyone was having any similar problems.  Any thoughts,
suggestions, clues, etc., would be appreciated.

--
Regards,

Phil Welch

2. Ipchains based Linux firewall and webserver on inside - can it be done?

3. Printing problems- Can't print plain ascii

4. dtmail and signature

5. printing problems: printer resets but no print

6. How do I configure Networking

7. Printing problems on a Solaris 8 print server

8. Read Only File System

9. Printing Problem - No Print

10. print problem, blank page printing

11. HP Printing Problem & Printing.HOWTO can't help!!!

12. Printing problem (Not printing first line) Help!

13. Printing Problem: Stair-Stepping when printing text