mounting CD-R results in "No medium found"

mounting CD-R results in "No medium found"

Post by a_do.. » Sat, 15 Apr 2000 04:00:00



Hello!..
I've got problems with CD-Rs which have more then one session on them.
My linux box (Debian 2.2, kernel 2.2.14) cann't mount them, it sayes "No
medium found", though NT box with the exactly same CD-drive can. There
is something strange about those discs, for the NT represents filenames
on them in the 8.3 format, I don't know why... But it's better then
nothing. OK, I tried to play with mount options, but in vane. Did
anybody has a trouble like this or does anybody have an idea what's
happening? It's really annoying...

thanks in advance, Valeriy

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

mounting CD-R results in "No medium found"

Post by Aaron Gin » Sat, 22 Apr 2000 04:00:00



> Hello!..
> I've got problems with CD-Rs which have more then one session on them.
> My linux box (Debian 2.2, kernel 2.2.14) cann't mount them, it sayes "No
> medium found", though NT box with the exactly same CD-drive can. There
> is something strange about those discs, for the NT represents filenames
> on them in the 8.3 format, I don't know why... But it's better then
> nothing. OK, I tried to play with mount options, but in vane. Did
> anybody has a trouble like this or does anybody have an idea what's
> happening? It's really annoying...

> thanks in advance, Valeriy

> Sent via Deja.com http://www.deja.com/
> Before you buy.

I don't know for certain, but it could be due to Microsoft using
Joliet extensions instead of Rock Ridge.  You need to explicitly
compile your kernel to support Joliet.  I believe that most distros
will support Joliet out of the box, but I'm not sure on this.

HTH,
Aaron

--
Aaron J. Ginn

Opinions mine, not Motorola's

 
 
 

mounting CD-R results in "No medium found"

Post by Dances With Cro » Sat, 22 Apr 2000 04:00:00


On 21 Apr 2000 13:22:33 -0700, Aaron Ginn

Quote:>> I've got problems with CD-Rs which have more then one session on them.
>> My linux box (Debian 2.2, kernel 2.2.14) cann't mount them, it sayes "No
>> medium found", though NT box with the exactly same CD-drive can. There
>> is something strange about those discs, for the NT represents filenames
>> on them in the 8.3 format, I don't know why... But it's better then
>I don't know for certain, but it could be due to Microsoft using
>Joliet extensions instead of Rock Ridge.  You need to explicitly

Nope.  CDs with Joliet extensions *also* have ISO9660 8+3 compliant
filenames, so that DOS won't barf.  Regardless, try that, and also try
"enable vendor-specific extensions for CD-ROMs" since the docs there
explicitly say to try enabling this if you can't mount multisession CDs.

This is an odd problem; only time I've seen anything like it is when I was
trying to burn multisession CDs and got the session info wrong, producing
horribly munged TOCs all over the place...

--
Matt G / Dances With Crows              \###| Programmers are playwrights
There is no Darkness in Eternity         \##| Computers are lousy actors
But only Light too dim for us to see      \#| Lusers are vicious drama critics
(Unless, of course, you're working with NT)\| BOFHen burn down theatres.

 
 
 

1. "mounted cd-rom" and "mounted samba share" icons on KDE 3.1 desktop

I have just installed Mandrake 9.1/KDE 3.1 on my machine. I noticed
that I now have a set of icons coresponding to automounted
directories. For example, I have both a "Mounted CD-ROM" and a
"Mounted Samba (Windows)"-type icon. While I think this is a nice
trick, I would like to remove these icons from my desktop (I prefer
the command line for such things). However, I could not find any way
to achieve this; right-clicking on the icons does not offer a "delete"
choice. I would greatly appreciate if somebody would enlighten me as
to what KDE option or configuration file do I have to modify.

Thank you in advance for all your help.

Gerd

2. Digital camera in KDE3.0.1

3. CDROM woes - "lost interrupt" - "no medium found"

4. XF86 on HP OmniBook 5700CT???

5. failed "Read Cd/Dvd Capacity";failed "Prevent/Allow Medium Removal"

6. ISDN through USB port

7. Help ppp configuration on R5

8. failed "Prevent/Allow Medium Removal" ;failed "Read Cd/Dvd Capacity"

9. GETSERVBYNAME()????????????????????"""""""""""""

10. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

11. How to avoid "media changed" message when mounting CD ?

12. "Mount Problem" Media not mounted correctly