glib-1.1.15 and gtk+-1.1.15 with RedHat 5.2

glib-1.1.15 and gtk+-1.1.15 with RedHat 5.2

Post by James H Timberlake II » Wed, 17 Feb 1999 04:00:00



i've been trying to get both glib and gtk installed to no avail.  i've
been installing glib first under root using ./configure, make, and then
make install.  everything goes ok.  then when i try ./configure for gtk,
it can't find glib.  i've read the INSTALL file and tried to make sure
the paths are ok, but i'm not sure what i'm doing.  is there something i
don't have set?  maybe a default PATH or something?  i'd appreciate any
help with this, i can't get gtkICQ installed and it's driving me nuts.
 
 
 

glib-1.1.15 and gtk+-1.1.15 with RedHat 5.2

Post by Dirko van Schalkwy » Thu, 18 Feb 1999 04:00:00



Quote:> i've been trying to get both glib and gtk installed to no avail.  i've
> been installing glib first under root using ./configure, make, and then
> make install.  everything goes ok.  then when i try ./configure for gtk,
> it can't find glib.  i've read the INSTALL file and tried to make sure
> the paths are ok, but i'm not sure what i'm doing.  is there something i
> don't have set?  maybe a default PATH or something?  i'd appreciate any
> help with this, i can't get gtkICQ installed and it's driving me nuts.

At y'er prompt type :
*
bash
cd  {insert the path you are installing gtk from}
export GLIB_CONFIG=/usr/local/bin/glib-config   ( or it might be
/usr/local/bin , I forget)
./configure

*
I hope it works and excuse my lack of English language.

Dirko

 
 
 

glib-1.1.15 and gtk+-1.1.15 with RedHat 5.2

Post by Ralf Lang » Thu, 18 Feb 1999 04:00:00


I don't know about RedHat, but on my SuSE 6.0 System, after installing
glib, you have to do 'ldconfig' as root. Then the configure script for
gtk works. Have you been trying to build x11amp0.9alpha* ? After
installing gtk, run ldconfig again.

Ralf

 
 
 

glib-1.1.15 and gtk+-1.1.15 with RedHat 5.2

Post by Jacques Oosthuize » Thu, 18 Feb 1999 04:00:00


Hi !

I had the same problem , but I have solved this . Make sure that the
directory where glib-config is in is in your path ( default is usualy
/usr/local/bin). Also make sure that the file /etc/ld.so.conf contains a
entry that point to the /usr/local/lib or where glib libraries are copied.
Then run ldconfig -v . the -v is just to show you what is happening . Good
luck you can mail me if you are still struggeling.


Quote:> i've been trying to get both glib and gtk installed to no avail.  i've
> been installing glib first under root using ./configure, make, and then
> make install.  everything goes ok.  then when i try ./configure for gtk,
> it can't find glib.  i've read the INSTALL file and tried to make sure
> the paths are ok, but i'm not sure what i'm doing.  is there something i
> don't have set?  maybe a default PATH or something?  i'd appreciate any
> help with this, i can't get gtkICQ installed and it's driving me nuts.

 
 
 

1. Installing PATCH GTK+-1.1.15-1.1.16

 Can someone tell me what I need to do to install this?

I'm trying to install Xchat-0.5.3 and I'm told that my current GTK
version will not work. I've downloaded the above mention upgrade of gtk.
However being the newbie I am, I don't have a clue as to what I'm
suppose to do with it.  It doesn't have a (.gz) or (.tar) extension.

Also if anyone knows of a   "Learn Linux in 21 Days" book or I settle
for  "Learn Linux in a Year" book.  Just something to make me feel less
helpless in my quest to escape the "Microsoft Strong Hold"!

JW

2. 1/3: Remove USR 56K voice modem specific PCI table entry.

3. Problem compiling glib-1.1.15

4. User-fs on newer kernels

5. guile-gtk and gtk+-1.1.13

6. patch 16/38: CLIENT: add ->setup_{write,commit}() for async write, part 1

7. Gnome + GTK+ + GLIB + Glade development under RedHat 5.2 ???

8. Linux box as a router.

9. recompilation of glib-1.2.8, gtk+1.2.8 for Redhat 6.2

10. gtk+-1.1.2 install problem

11. Need Help Compiling gtk+-1.1.9

12. gtk+-1.1.12 installation problem

13. prob w/ bind-4.9.6-1.1 (RedHat 4.2 rpm)