Help with Imake

Help with Imake

Post by roo » Tue, 22 Apr 1997 04:00:00



Hi!

I'm running Mklinux on a PowerMac, and used the preinstalled Imake a
couple of times while compiling new software.
But I must have deleted some files, as the Imake won't run anymore.

When executing:


mv -f Makefile Makefile.bak
imake -DUseInstalled -I/usr/X11R6.3/lib/X11/config
imake: No such file or directory
imake: Cannot exec /lib/cpp.
  Stop.
imake: Exit code 1.
  Stop.

I get this. I looked for the Imake on the net but couldn't find it. So I
guess it is part of another packages.

Does anybody know which on it is...??

Thanx Juergen

--
Juergen Helmers                 the Rockefeller University

fon: 1.212.327.8896
IP:  129.85.13.212

 
 
 

Help with Imake

Post by qua.. » Wed, 23 Apr 1997 04:00:00



> I get this. I looked for the Imake on the net but couldn't find it. So I
> guess it is part of another packages.
> Does anybody know which on it is...??

Imake is part oft the X-Project.
So you could find it anywhere on ftp://ftp.xfree86.org/pub/XFree86

regards

Klaus Reger

--

-----------------------------------------------------------------------

| |/ /   | _ \     | Schloss Laibach | Phone (office): +49 6282 9227-15
| < <  _ |   <  _  | 74677 Doerzbach | Phone (priv.) : +49 7937 80112
|_|\_\<_>|_|\_\<_> | Germany         | Fax   (priv.).: +49 7937 80113
-----------------------------------------------------------------------

 
 
 

Help with Imake

Post by Curtiss Cicc » Wed, 23 Apr 1997 04:00:00



> Hi!

> I'm running Mklinux on a PowerMac, and used the preinstalled Imake a
> couple of times while compiling new software.
> But I must have deleted some files, as the Imake won't run anymore.

> When executing:


> mv -f Makefile Makefile.bak
> imake -DUseInstalled -I/usr/X11R6.3/lib/X11/config
> imake: No such file or directory
> imake: Cannot exec /lib/cpp.
>   Stop.
> imake: Exit code 1.
>   Stop.

> I get this. I looked for the Imake on the net but couldn't find it. So I
> guess it is part of another packages.

> Does anybody know which on it is...??

  This is probably just a missing link to your cpp binary. Check to
make sure /usr/lib/gcc-lib/ is present on your system; this is assuming
you do have GCC installed. /lib/cpp needs to be a symlink pointing to
where your cpp binary can be found at. On my system it points to
/usr/bin/cpp which is a symlink to the true location of my cpp binary.

Fix your link, then Imake should work fine for you unless of course
there are other problems.

--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
= Curtiss Cicco             =


=-=-=-=-=-=-=-=-=-=-=-=-=-=-=