where the hell is libposix???

where the hell is libposix???

Post by Bill Dosset » Sat, 03 Feb 2001 00:35:36



Help!!!  I'm trying to build the latest version
of Perl on RedHat 7.0 and the libposix is missing....

how can this be?  Does anyone know where
it's gone.. I've downloaded updates, and there
is a new glibc, and it creates a i386-glibc dir
with a lib and libposix.a in it, but I'm not sure
which lib is which now... can I copy that lib
into /usr/lib?  there is absolutely no docs about
why this is....

Thanks

Bill

 
 
 

where the hell is libposix???

Post by D. Stimit » Sat, 03 Feb 2001 01:33:17



> Help!!!  I'm trying to build the latest version
> of Perl on RedHat 7.0 and the libposix is missing....

> how can this be?  Does anyone know where
> it's gone.. I've downloaded updates, and there
> is a new glibc, and it creates a i386-glibc dir
> with a lib and libposix.a in it, but I'm not sure
> which lib is which now... can I copy that lib
> into /usr/lib?  there is absolutely no docs about
> why this is....

> Thanks

> Bill

I don't anything about the particular lib, but I do have the .a version
of it on my system. You might be interested in:
http://filewatcher.org/
(search for it there; I saw both libposix and libposix4)

 
 
 

1. help me i am in hell...

        Well, not exactly.  I was up till 2:30 this morning patiently
downloading all 5 megs of the "mini" distribution of linux from
yggdrasil(sp?).  When the last file was finally received I unpacked and
installed with no problems.  The difficulty is when I try to actually
start the damn thing! I run the linux.bat file and the process begins.  
It gets to the point where it says "calibrating delay loop - ok 33.22
BogoMips." Then under that it says "failed," then waits a couple of
seconds and continues.  So far so-so. Then after a few more lines of
commments (not errors) comes the killer: "hd.c - ST-506 interface disk
with more than 16 heads detected, probably due to non-standard sector
translation. Giving up!" then about a screenfull of error messages that
all seem to stem from this one i.e. "kernal panic - unable to mount root",
"MSDOS bread failed" etc...

        My system is as follows:
        486DX2 - 66 clone with 8MB ram, AMI BIOS, SiS Motherboard
        Western Digital Caviar 540 MD HardDrive
        (requires Ontrack Disk Manager, a dynamic drive overlay to access
the entire 540 Megs.  I believe this to be the source of the errors.)

        Has anyone successfully installed this on such a hard drive? I
_really_ do not want to have to back up, and then reformat my drive to
528 megs without the drive manager and then reinstall everything!! The main
reason I got the mini linux is to avoid doing this.  Any ideas? I'm a
total newbie to linux/unix, but am quite adept at other aspects of computing.

                                        Thanx,

                                        PM

--

2. Trouble with X Window

3. PCL poscript I am in printing hell

4. libXaw / libXaw3d problems

5. help me i am in hell...

6. redhat 6.2 and NAT with iproute

7. If X is directed to a windows box, am I doomed to hell?

8. Reading and writing M

9. PCL poscript I am in printing hell

10. I am in Acculogic Hell

11. Iptables - what the hell am I doing wrong ?

12. ne2000 from hell..I tell you..from hell

13. This clone thing...am I stupid, or am I right?