problem dynamic libraries (libXt.so.6 etc.)

problem dynamic libraries (libXt.so.6 etc.)

Post by Martijn Brouw » Tue, 25 Jan 2000 04:00:00



I have a problem with my dynamic libraries. Some programs like netscape vs. 3,
downloades as binary refuse to start, giving the messages libXt.so.6 not
found. rpm reports failed dependencies when I try to install a program.
However, these libraries are present on my system, and work correctly: xterm
uses them also and works fine.

Does anybody know what the problem is and how I can solve it?

Greetings,

Martijn

_____________________________________________________________

 
 
 

problem dynamic libraries (libXt.so.6 etc.)

Post by Paul Kimo » Tue, 25 Jan 2000 04:00:00



> I have a problem with my dynamic libraries. Some programs like netscape vs. 3,
> downloades as binary refuse to start, giving the messages libXt.so.6 not
> found. rpm reports failed dependencies when I try to install a program.
> However, these libraries are present on my system, and work correctly: xterm
> uses them also and works fine.

Perhaps netscape is a libc5 program and your system uses libc6 (or
vice versa).  What does "ldd /path/to/netscape" say?

(To run libc5 programs linked against libblah.so, you need a libc5 version
of libblah.so.  The libc6 version will not do.)

--


 
 
 

problem dynamic libraries (libXt.so.6 etc.)

Post by Martijn Brouw » Wed, 26 Jan 2000 04:00:00




>> I have a problem with my dynamic libraries. Some programs like netscape vs.
> 3,
>> downloaded as binary refuse to start, giving the messages libXt.so.6 not
>> found. rpm reports failed dependencies when I try to install a program.
>> However, these libraries are present on my system, and work correctly: xterm
>> uses them also and works fine.

>Perhaps netscape is a libc5 program and your system uses libc6 (or
>vice versa).  What does "ldd /path/to/netscape" say?

No they require the libc6 libraries.

_____________________________________________________________

 
 
 

1. running X problem cant open library 'libXt.so.6'

Hi running a Slackware 3.0.30 Linux box and a S3 Video Card Trio32 , Ive
had X working once before on the same video card
but the problem seems to be loading the librarys , ive checked file
paths and sim links all looks as it was before , any ideas ?

Thanks regards
Sean.

2. Help with modules

3. Problem with library libXt.so.6

4. File access

5. Problem: can't find library 'libXt.so.6'

6. How to use Ctrl+s in JOVE?

7. ld problem : Shared library required libXt.so.3

8. bind9 fbsd 5 fix

9. libXt.so.3.1.0 and libXt.so.6.0, can coexist?

10. Using a dynamic library from another dynamic library

11. help: "emacs:can't load library 'libXt.so.6'" . . .

12. can't find library 'libXt.so.6'

13. Can't load library 'libXt.so.6'