XFree86-4.0 rpm installation

XFree86-4.0 rpm installation

Post by Silviu Minu » Thu, 18 May 2000 04:00:00



I'm trying to satisfy the dependencies for XFree86-4.0. Among many other
things, it requires libncurses.so.5.
However, trying to install ncurses-5 breaks dependencies for a whole
bunch of other packages, most notably util-linux, which provides crucial
system programs, such as login and fdisk. These packages require
ncurses-4.x.

How does one go about this? Would bad things happen to me if I force
ncurses-5? If it wasn't for the login program, I'd give it a try myself.
Has anybody tried this?

I'm running RedHat6.0 (but now it is close to 6.2 probably, due to
continuous upgrades that I make). Oh, did I mention it's all about rpms?

 
 
 

XFree86-4.0 rpm installation

Post by Sam E. Trenhol » Thu, 18 May 2000 04:00:00


Quote:>I'm running RedHat6.0 (but now it is close to 6.2 probably, due to
>continuous upgrades that I make). Oh, did I mention it's all about rpms?

rpm --nodeps foo.i386.rpm

- Sam

--
Please post, and not email, questions you have about my answers
Go to http://samiam.org/cgi-bin/mailme to get my email address

 
 
 

XFree86-4.0 rpm installation

Post by Silviu D Minu » Thu, 18 May 2000 04:00:00


Thanks!
My question wasn't an rpm question though. I know about --nodeps. I was
wondering what would happen if I did break the dependencies. Did anyone try
to run util-linux with ncurses-5? Would that ruin the whole system?

> >I'm running RedHat6.0 (but now it is close to 6.2 probably, due to
> >continuous upgrades that I make). Oh, did I mention it's all about rpms?

> rpm --nodeps foo.i386.rpm

> - Sam

> --
> Please post, and not email, questions you have about my answers
> Go to http://samiam.org/cgi-bin/mailme to get my email address

 
 
 

1. RedHat 3.0.3 Installation - FAILED TO OPEN "/mnt/var/lib/rpm/packages.rpm"

Hi,

Ok, here's the thing... I'm installing Linux RedHat from my Dos partition.
All the desired packages are in the "C:\RedHat\RPMS" directory.  The
install does everything as it should (well everything seems normal anyway),
but when it gets to the part to start installing files to my Linux
partition I get the following dialog box error:
         Package install of apps.001 failed with error:
           failed to open /mnt/var/lib/rpm/packages.rpm
This is the first package in the Applications set.  I get the same error
message for all the other packages too!

I went to a shell during the install (Alt-F2) and checked the "/mnt"
directory.  Sure enough, IT'S EMPTY!!  Why is this?

For refence sake, I'm using the "Boot0000" boot disk (my CD-Rom is a
Toshiba IDE and I have no ethernet card).  

Can anyone help?  Would you mind sending any responses via e-mail?  Thanks!


2. network connection in UNKNOWN state?

3. XFree86-4.0.1 src rpm build problem

4. Problem with unix:/7101 ?

5. Looking for XFree86-4.0.x rpms for Redhat 6.x?

6. ATI ┬žD Rage IIc

7. xfree86-4 installation for newbies!!!

8. Burner Problem

9. XFree86-4.0-0.16c installation problems

10. RPM for Uwin - cannot open file //var/lib/rpm/nameindex.rpm

11. RPM corrupted, rpm --rebuilddb fails and there is data in the /var/lib/rpm directory

12. RPM Crashes with "//var/lib/rpm/packages.rpm not found"

13. RPM: cannot open //var/lib/rpm/packages.rpm