help needed to bring up a pcmcia modem.

help needed to bring up a pcmcia modem.

Post by Lupei Zh » Sun, 07 Jan 2001 03:34:11



Hi,

   I installed RH7.0 on my Dell4000 laptop. I am having problem to get
the modem (Xircom cardbus) working. Linux recognizes the card as shown
from "cardctl ident":

Socket 0:
  product info: "Xircom", "CardBus Ethernet II 10/100", "CBEII-10/100",
"1.03"
  manfid: 0x0105, 0x0103
  function: 6 (network)
Socket 1:
  product info: "Xircom", "CardBus Modem 56WG", "CBM56WG", "1.00"
  manfid: 0x0105, 0x1000
  function: 2 (serial)

but it failed to configure the card while excuting "modprobe serial_cs"
and complains:
serial_cs: ParseTuple: No more items

can anyone help me to solve this problem.  I've put /var/log/messages
below.

thanks

Lupei

here are the messages from /var/log/message:

pcmcia: Starting PCMCIA services:
pcmcia:  modules
kernel: Linux PCMCIA Card Services 3.1.19
kernel:   kernel build: 2.2.16-22 #1 Tue Aug 22 16:49:06 EDT 2000
kernel:   options:  [pci] [cardbus] [apm]
kernel: PCI routing table version 1.0 at 0xfbd80
kernel:   00:03.0 -> irq 11
kernel:   00:03.1 -> irq 11
kernel: Intel PCIC probe:
kernel:   TI 1420 rev 00 PCI-to-CardBus at slot 00:03, mem 0x68000000
kernel:     host opts [0]: [ring] [serial pci & irq] [pci irq 11] [lat
32/32] [b
us 32/34]
kernel:     host opts [1]: [ring] [serial pci & irq] [pci irq 11] [lat
32/32] [b
us 35/37]
kernel:     ISA irqs (scanned) = 3,4,7,9,10 PCI status changes
pcmcia:  cardmgr.
rc: Starting pcmcia:  succeeded
cardmgr[469]: starting, version is 3.1.19
cardmgr[469]: watching 2 sockets
kernel: cs: IO port probe 0x0c00-0x0cff: excluding 0xcf8-0xcff
kernel: cs: IO port probe 0x0800-0x08ff: excluding 0x800-0x84f
kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x290-0x297
0x378-0x37f 0x4d0
-0x4d7
kernel: cs: IO port probe 0x0a00-0x0aff: clean.
kernel: cs: cb_alloc(bus 35): vendor 0x11c1, device 0x0420
kernel: cs: cb_alloc(bus 32): vendor 0x115d, device 0x0003
cardmgr[469]: initializing socket 0
cardmgr[469]: socket 0: Xircom CBEII-10/100 CardBus 10/100 Ethernet
cardmgr[469]: executing: 'modprobe cb_enabler'
cardmgr[469]: executing: 'modprobe tulip_cb'
kernel: cs: cb_config(bus 32)
kernel:   fn 0 bar 1: io 0x200-0x27f
kernel:   fn 0 bar 2: mem 0x6000d000-0x6000d7ff
kernel:   fn 0 bar 3: mem 0x6000c000-0x6000c7ff
kernel:   fn 0 rom: mem 0x60008000-0x6000bfff
kernel:   irq 11
kernel: tulip_attach(device 20:00.0)


kernel: eth0: Xircom Cardbus Adapter (DEC 21143 compatible mode) rev 3
at 0x200,
 00:10:A4:11:76:E6, IRQ 11.
kernel: eth0:  MII transceiver #0 config 3100 status 7809 advertising
01e1.
cardmgr[469]: executing: './network start eth0'
pumpd[512]: starting at (uptime 0 days, 0:00:37) Sat Feb  3 09:57:01
2001
xinetd: xinetd startup succeeded
lpd: lpd startup succeeded
keytable: Loading keymap:
keytable: Loading /usr/lib/kbd/keymaps/i386/qwerty/us.kmap.gz
keytable: Loading system font:
rc: Starting keytable:  succeeded
pumpd[512]: configured interface eth0
cardmgr[469]: + Determining IP information for eth0... done.
cardmgr[469]: initializing socket 1
cardmgr[469]: socket 1: Serial or Modem
cardmgr[469]: executing: 'modprobe serial_cs'
kernel: serial_cs: ParseTuple: No more items
sendmail: sendmail startup succeeded
gpm: gpm startup succeeded
cardmgr[469]: get dev info on socket 1 failed: Resource temporarily
unavailable