rxvt .Xdefaults

rxvt .Xdefaults

Post by Saadiq Rodgers-Ki » Mon, 20 Apr 1998 04:00:00



I'm having a hard time trying to set my defaults for rxvt in X.  Anyone got a
pointer to a little How-To that could help me out?  By default, it seems that
rxvt uses an awful font and has a white background.  I have been trying to
change these by default instead of having to give it commandline args every
time.  The best I can do is if I put
rxvt*font:      helvetica
... in my .Xdefault then if rxvt can't find the font, it gives my Helvetica,
which is what I want.  If it can find font it starts up and I get nothing but
a scroll bar and a vertical sliver of a window.  Go figure.  Also...
rxvt*background:        black
rxvt*foreground:        white
...these don't seem to have any effect either.  Any help?  Thanks.

--
Saadiq
-=>take NO_JUNK out of the email address to reply<=-
saadiqr AT princeton DOT edu

 
 
 

rxvt .Xdefaults

Post by Roy Stogn » Tue, 21 Apr 1998 04:00:00



Quote:>... in my .Xdefault then if rxvt can't find the font, it gives my Helvetica,
>which is what I want.  If it can find font it starts up and I get nothing but
>a scroll bar and a vertical sliver of a window.  Go figure.  Also...
>rxvt*background:        black
>rxvt*foreground:        white
>...these don't seem to have any effect either.  Any help?  Thanks.

Those two should work, and "man rxvt" will show you all the settings
you can change like this.  Remember, though, .Xdefaults (you did
remember the s, right?) is only read when you restart X or run "xrdb
~/.Xdefaults".
---
Roy Stogner

 
 
 

1. rxvt and .Xdefaults

Hi,

I have a question: i am setting up an x server and have chosen rxvt as
default terminal. Now most people prefer white text on a black background,
but others prefer the reverse.

so i thought i just put

rxvt*background:        black
rxvt*foreground:        white

in the /usr/X11R6/lib/X11/app-defaults/rxvt, and for those that want to
have it the other way round, I create a .Xdefaults file in their home
directory, with the colors reversed;

However, the .Xdefaults is apparently not read ? everyone gets the default
behaviour (white text on a black background) , even those that have an
.Xdefaults file with the following entries:

rxvt*background:        white
rxvt*foreground:        black

Now I get the impression that first the .Xdefaults file is read, and then
the app-defaults/Rxvt is applied, because if the app-defaults/Rxvt does
not exist, the values in ~/.Xdefaults are used. if both exist, the
app-default/Rxvt values are used.

what files should i edit to get the behaviour i want ?

Thanks,

Tom.

2. Redhat 6.1 kernel version.

3. Xdefaults for Stealth 32 & NEC3D

4. Dead loop on netdevice eth0

5. dircolors and .Xdefaults

6. No logon prompt for ftp and telnet

7. .Xdefaults /.xinitrc for xterm windows

8. Addonics C143 UVGA refresh rates?

9. Irritating Xdefaults problem

10. what is .Xdefaults in rh7.1?

11. xterm .Xdefaults settings

12. seyon & .Xdefaults

13. .Xdefaults