Trouble creating zdisk, "unable to mount root"

Trouble creating zdisk, "unable to mount root"

Post by James Y C » Tue, 28 May 1996 04:00:00



Hello.  I wonder if anyone could provide a tip.  I'm trying to use my
existing Linux machine to compile a kernel for my small new  one, but
every zdisk I make gets a kernel panic when it tries to mount the root
filesystem.  Everything is from the Slakware 3.0 cdrom, but with the IP
Masquarading patches applied (and perhaps a slightly newer gcc).

The "idenet" kernel that came from the CDROM boots fine, both from
floppy and from HD using LILO, but no kernel I compile (and I've
compiled kernels for my old machine just fine) will boot.  I've even
tried taking the Slakware idnet config and building a new idenet
kernel, and it fails.

It seems fine until it has to mount the root, when it gives MSDOS and
HPFS messages, as if it were trying to mount the ext2 as one of those.
It also says something about a 512 byte transaction block size.

I am running out if ideas. Any suggestion would be welcome.

Thanks

 
 
 

1. trouble with zdisk boot: unable to mount root fs

Hello.  I wonder if anyone could provide a tip.  I'm trying to use my
existing Linux machine to compile a kernel for my small new  one, but
every zdisk I make gets a kernel panic when it tries to mount the root
filesystem.  Everything is from the Slakware 3.0 cdrom, but with the IP
Masquarading patches applied (and perhaps a slightly newer gcc).

The "idenet" kernel that came from the CDROM boots fine, both from
floppy and from HD using LILO, but no kernel I compile (and I've
compiled kernels for my old machine just fine) will boot.  

It loads up to when it has to mount the root, when it gives MSDOS,
UMSDOS, and HPFS messages, as if it were trying to mount the ext2 root
fs as one of those. It also says something about a 512 byte
transaction block size.

I am running out if ideas. Any suggestion would be welcome.

Thanks

2. OpenBSD/Sparc and SunOS Netscape

3. GETSERVBYNAME()????????????????????"""""""""""""

4. XFree 4.0.2 and Gnome

5. If you see "VFS : Unable to mount root fs...", check this out.

6. FW: X11R6 public fix #13 now available

7. "VFS: unable to mount root" after kernel rebuild

8. adaptec 1510

9. "KP:VFS:Unable to mount root fs on nn:n0"

10. "2842 controller - Kernel panic VFS: unable to mount root fs on 1:02"

11. "unable to mount root fs" seems common prob....

12. What's mean "Kernel panic: VFS:Unable to mount root fs on 08:02"

13. Linux Install: "unable to mount root fs on 0b:00"