RH 5.0 Install Prob: "Can't Load libXext.6.0"

RH 5.0 Install Prob: "Can't Load libXext.6.0"

Post by T » Fri, 02 Jan 1998 04:00:00



Upgrade from RH 4.2 -> 5.0 ("Official" release) on relatively fresh RH
4.2 installation evidently breaks some sort of link to libXext. Both
Netscape and KDE window manager are lost without it.

What is the fix for a "can't find" type error? The Red Hat errata does
not seem to address this problem yet.

Regards,
TL

 
 
 

RH 5.0 Install Prob: "Can't Load libXext.6.0"

Post by Glynn Clement » Fri, 02 Jan 1998 04:00:00



> Upgrade from RH 4.2 -> 5.0 ("Official" release) on relatively fresh RH
> 4.2 installation evidently breaks some sort of link to libXext. Both
> Netscape and KDE window manager are lost without it.

You should have the following in /usr/X11R6/lib:

cerise:~$ ls -l /usr/X11R6/lib/libXext.so*
lrwxrwxrwx   1 root     root           14 Nov 19 17:05 /usr/X11R6/lib/libXext.so -> libXext.so.6.3*
lrwxrwxrwx   1 root     root           14 Nov 19 17:05 /usr/X11R6/lib/libXext.so.6 -> libXext.so.6.3*
-rwxr-xr-x   1 root     root        52442 Nov 19 17:05 /usr/X11R6/lib/libXext.so.6.3*

If you have the actual library but not the symlinks, just make the symlinks.

If you don't have the library, then you'll probably need to redo the
installation of the appropriate bit of RedHat.

If you have the library and the symlinks, but they're not being
recognized, then it's probably got something to do with libc-5
programs not liking libc-6 libraries, in which case you'll probably
need to get a version of libXext that was built with libc-5, and
install it yourself in an appropriate place.

--


 
 
 

RH 5.0 Install Prob: "Can't Load libXext.6.0"

Post by Colonel Pani » Mon, 05 Jan 1998 04:00:00


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


> Upgrade from RH 4.2 -> 5.0 ("Official" release) on relatively fresh RH
> 4.2 installation evidently breaks some sort of link to libXext. Both
> Netscape and KDE window manager are lost without it.
> What is the fix for a "can't find" type error? The Red Hat errata does
> not seem to address this problem yet.

ldconfig should make symlinks for all your libraries; and it should be
running on boot.  You can check for the missing libraries with ldd,
e.g., ldd /usr/X11R6/bin/netscape.  Your /etc/ld.so.conf file should
have a list of places for ld & ldconfig to look for libraries that are
not in the "trusted" dirs, /lib and /usr/lib.  So, for example,
/usr/X11R6/lib should be in there.  The environmental variable
LD_LIBRARY_PATH can also be used to give this information to ld.

mp

 +=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=+  
 | sheep, n.  A stupid woolly creature, meant to be fleeced; a dupe;   |
 | an individual who uses 'no-spam' headers in UseNet newsgroups.      |
 +=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=+
 | Linux 2.0.32 -> AMD 5x86-133  | pgpk -a finger://teleport.com/looie |
 +=-=-=-=-=+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=+

 +=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=+

-----BEGIN PGP SIGNATURE-----
Version: PGP for Personal Privacy 5.0
Charset: noconv

iQA/AwUBNK9VZUd/HEJs3CCeEQJX/wCeJXQ0YHysl2qIQC797mwlFNowZNIAnApX
4E67AH/IAt88BDBxEZCfi1T8
=vzNw
-----END PGP SIGNATURE-----

 
 
 

1. Error "Install bootloader" RH 5.0 & 6.0

Anyone know why I could not install LILO onto the First sector of boot
partition on my Tecra 780 during initial install?  I have never seen this
error before and have had Linux on my laptop before.  I have tried to delete
all partitions and start over and I still get this error.  I made a bootdisk
so I can boot up my machine, but I would prefer not to boot from floppy.

Mike

2. LOCPATH env variable in AIX

3. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

4. Newusers & accts: logged off immediately

5. GETSERVBYNAME()????????????????????"""""""""""""

6. Solaris7 on Sparc5

7. newly built kernel "loads" but doesn't "uncompress"

8. HELP!!! To work with HP scanjet 4400c Scanner for RedHat8

9. Install Prob: Hangs on "Loading Drivers"

10. RH 6.0 Hard Drive install "symlink" error message

11. Again: "Infamous" RH 5.0 Install Panic (CDROM not seen)

12. RH 6.0 Hard Drive install "symlink" error message

13. "Host name lookup failure" error RH 5.0 to RH 5.2