Telnet login doesn't run /etc/profile or $HOME/.profile

Telnet login doesn't run /etc/profile or $HOME/.profile

Post by S.D. Mottra » Thu, 08 Feb 1996 04:00:00



Hi,

A minor but irritating problem I'm having with my system (Linux-FT 1.1,
kernel 1.2.13, Pentium 90). When logging in from a remote machine by
telnet (e.g. MS-telnet in Windoze for workgroups), the telnet correctly
logs the user in, complete with starting the right shell etc, but doesn't
run /etc/profile or $HOME/.profile, so the paths, prompts and environment
variables don't get set correctly.

I'm a bit puzzled by telnet logins : they don't seem to be handled by a
getty, so I presume the telnet daemon is responsible for negotiating the
login. So, is this a problem with telnet daemon configuration, or a
compile option, or just not possible ? The telnet and telnetd man pages
are very sparse and don't say anything about this. I also couldn't find
anything in the NET-HOWTO or network configuration guide.

Any advice very gratefully received,

Steve

-----------------------------------------------------------------------------
| Steve Mottram                                                             |
|                                                                           |
| University Department of Anaesthesia  |    Internal Phone : LRI 5694      |
| Leicester Royal Infirmary             |    Phone  :  +44 (0)116 258 5291  |
| Leicester LE1 5WW                     |    Fax    :  +44 (0)116 285 4487  |

|---------------------------------------------------------------------------|
| Witty bit deleted due to budget cuts.                                     |
|---------------------------------------------------------------------------|

 
 
 

1. cmdtool doesn't source /.profile or /etc/profile

When I bring up a cmdtool (solaris 2.6) via an X interface on my NT4.0
desktop, I am greeted with a "#" prompt which means that my .profile hasn't
run.  This means that when I login, I have to ". /.profile" and ".
/etc/profile".  However, everything works fine if I am actually working at
the machine.

Any thoughts??

Thanks,
Mike
Westwood, MA

2. ps cannot generate /tmp/ps_data, Solaris 2.3

3. /etc/profile or $HOME/profile

4. Oracle 8.i on linux (SUSE 6.2) - unresolved symbol

5. KDE won't start if my .profile or /etc/profile has stty commands

6. Help on ufsrestore

7. "Screen" prgram: New shells won't read /etc/profile or ~/.profile?

8. Linux with Iomega ZIP Drive(s)

9. ksh not reading /.profile or /etc/profile

10. Not reading /etc/profile or .profile

11. Konsole doesn't source /etc/profile

12. /etc/profile doesn't get read

13. rsh xterm -ls -e command doesn't see /etc/profile