Compiling sasteroids 1.5

Compiling sasteroids 1.5

Post by Robert Bagins » Sun, 30 Apr 1995 04:00:00



I am using kernel v 1.2.6 and gcc v2.6.3.  I would like to compile Sasteroids
v1.5. When I run the Makefile I get several pages of warnings and the
compile quits. I can compile the kernel with no problem. Is there
anything special I need to do because Sasteroids is written in C++ to get
it to compile correctly. Has anyone else attempted to do this compile?
Any help would be appreciated.

Bob

 
 
 

1. Sasteroids 1.5 (with digital sound) released

Hello,

In space, no one can hear you scream... But you can hear asteroids blowing
up. This is to announce the release of Sasteroids v1.5, a svgalib (not X)
asteroids-type game with joystick support.

Actually, sasteroids has been kicking sound since the beginning of Sept.
Those of you who have the beta-2 version don't really have to get this one.

There is also a new snd+gfx package (sound + graphics) which includes most
of the files needed to change the sound and bitmap graphics in the game. You
DON'T need this file if all you want to do is play the game.

There are both binary and source releases.  The binary release is for those
of you without gcc/g++ 2.5.8 or svgalib 1.20 installed.

I have uploaded it to: sunsite.unc.edu
        /pub/Linux/Incoming/sast1.5-src.tar.gz  (source)
        /pub/Linux/Incoming/sast1.5-snd+gfx.tar.gz  (sound+graphics)
        /pub/Linux/Incoming/sast1.5-bin.tar.gz  (binary)

where it will probably be moved to:
        /pub/Linux/games/video/

Also tsx-11.mit.edu where it will probably be moved into:
        /pub/linux/sources/usr.games/sast1.5-src.tar.gz
        /pub/linux/sources/usr.games/sast1.5-snd+gfx.tar.gz
and..
        /pub/linux/binaries/usr.games/sast1.5-bin.tar.gz

***
Note: You need gcc 2.5.8, c++ libraries, and svgalib 1.2.0 (or greater)
to compile the source release. Svgalib is available at sunsite.unc.edu,
tsx-11.mit.edu and other linux ftp site. You'll need linux 1.1.4? and up to
hear the groovy sound.
***

--brad

See and hear my band! Even better, order my CD ($10 Can.) :-)
http://imagineer.com/euphony/music/Guppy/

--

PLEASE remember Keywords: and a short description of the software.

2. Network restart script for DSL connection

3. problem compiling firefox 1.5

4. DOSEMU+Stealth 64Dram=no graphics

5. mutt 1.5 compile help Solaris 9

6. argv ==> stdin, got it

7. ARGUS 1.5 compile blows up on BSDI 2.1

8. How to set environment and take args??

9. Need help compiling ARGUS 1.5 on BSDI 2.1 or AIX 3.2.5 (RS6000)

10. ddd-3.1.5 fails to compile on RH 6.0 upgrade

11. SoundBl 1.5 + MIDI - kernal compile error

12. Has anyone compiled Ghostview 1.5?

13. NEED HELP compiling Argus 1.5 on AIX 3.2.5